• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Error 0x8007025D - a mess - bad RAM?

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

zaarin_2003

New Member
Joined
Nov 13, 2016
Hi,

Windows 10 Home 64 bit

Forgive the long story, but I feel as much detail as possible is a good thing and I'd be really grateful for some help please!

A couple of months ago I decided to enable XMP mode on my Asus Z87-K motherboard because userbench website reported that my RAM was Corsair Vengence clocked at 1800mhz and was running slowly. I checked the BIOS and sure enough, XMP was disabled and the RAM was running at 1333Mhz. Upon restarting, I recall quickly receiving a BSOD. I put it down to what I'd just done and turned XMP off again. I wasworried I'd overclocked and damage my RAM or something.

Since then, I started to notice the occasional BSOD - usually MEMORY MANAGEMENT, but not always. Kernal security one time, something about a corrupt page file. They were rare. One every few days, but more than I was comfortable with.

Fast forward to last week and the BSOD had gotten a little worse. Strangely, they never happened whilst doing something strenuous, like playing a graphically intensive game, but whilst browsing on Edge.

Now yesterday: having become bored of the occasional BSOD, I tried running sfc /scannow but it said resource protection couldn't complete the scan. I received a similar error running the DSIM fix to verify Windows 10.

I then noticed whilst working that MS Office then had weird problem - updates failed with a 'something went wrong' error. I tried uninstalling MS Office and received a similar error. A MS tech had no ideas. "Something is seriously wrong with your OS" he said. He suggested a repair in place upgrade using the media creation tool.

I did that and found that sfc /scannow worked, but the same problem with Office persisted and the BSOD happened almost immediately.

I performed a reset of Windows 10, the next most intrusive option. I kept my files, but chose to lose the apps etc. So it was more or less a clean install.

BSOD fairly quickly.

So, I thought, f -it. I downloaded Windows 10 onto a USB, restarted, deleted my HD partitions and decided upon a clean install.

That's where I am now. It gets part way and then pops up with the error 0x8007025D - important files could not be installed.

I have tried removing all hardware except for the monitor, keyboard and mouse (corded) and the USB stick with the install on it. Nothing helps. I now have no OS but the install fails with this message.

UPDATE - I also tried to install from a DVD so don't have the USB stick attached either. Nope!

Please help.

Does anyone have any ideas? Could it be the RAM? I don't want to go too far putting thoughts in anyone's head though. Could it be something else?

Another questions... if new RAM doesn't help - what can I try??

Thank you

Matt

Update - I ran Memtest86+...... 15 thousand errors!
 

mimart7

Member
Joined
Jun 6, 2011
Now, you need to find out which stick is the issue. Although, I have found out even after replacing suspect memory, the motherboard was ultimately the problem. Granted, this isn't usually the case, but I have seen it.
 

BobbyBubblehead

Member
Joined
Jan 29, 2009
Enter bios and change ahci mode to ide.

You can battle with turning it back post install.

Should you still get 15,000 errors then something much more funky is going down.

(vaguely recall my Asus laptop being an *** about win 10 64bit for a day and half) :)
 
OP
Z

zaarin_2003

New Member
Joined
Nov 13, 2016
Sorry about the duplication!

Thanks BobbyBubblehead. Would you mind please explaining what that means and why it might work?
 

BobbyBubblehead

Member
Joined
Jan 29, 2009
Well in the case of my Asus laptop windows 10 64bit didn't have the relevant 64bit ahci drivers for the Intel chipset during install causing the system to hang or throw up various error codes.

So switching to ide legacy in bios enabled me to install the operating system without issue then once the system was in place I could switch over to the newer ahci protocol.

Ahci stands for advanced host controller interface which is the newer method used to enable hard drives to communicate with the rest of the system namely your motherboards hard drive controller and boards chipset. ide which stands for integrated drive electronics has more compatibility which is what you need while installing the operating system on machines causing controller issues at the initial early stage. once the operating system is seated and the boards chipset drivers are installed and up to date you can proceed to switch to ahci mode and gain the performance benefits and features.

To switch to ahci mode...

1. Right-click the Windows Start Menu. Choose Command Prompt (Admin)

2. Type this command and press ENTER: bcdedit /set {current} safeboot minimal

3. Restart the computer and enter BIOS Setup (the key to press varies between systems)

4. Change the SATA Operation mode to AHCI from either IDE or RAID (again, the language varies)

5. Save changes and exit Setup and Windows will automatically boot to Safe Mode.

6. Right-click the Windows Start Menu once more. Choose Command Prompt (Admin)

7. Type this command and press ENTER: bcdedit /deletevalue {current} safeboot

8. Reboot once more and Windows will automatically start with AHCI drivers enabled.

9. Sit back and enjoy warm fluffy satisfied feeling inside :clap:

Oh, and use the dvd not USB stick to install (USB ports may have 64bit driver issues too during install)
 
Last edited: