• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

F@H stats in your sig: not just for Linux anymore!

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.
My concern with hard-coding "c:\mksig" in mksig is that if they change it to "F:\mksig" but also choose to autoupdate, it'll write over with $dir="c:/mksig" everytime there's a new mksig update. I can have gui.pl modify the $dir in mksig before running, but I really don't want to touch your code :-/

So far the relative paths work, just like how your original sig_gen stored stfd.html in the mksig directory without directing a absolute path. So if mksig doesn't detect sig, sig_gen, or mksig.conf, wouldn't it create it in the same directory that mksig lives too (just like stfd.html)? Wouldn't this be the way to go, so that we could place mksig.pl in any directory we'd like, without altering the mksig code? Plus, it shouldn't hurt the current users because everyone has installed mksig and sig_gen into the same directory. C'mon you know you like this way better ;) But I"ll see if I can work Win32::TieRegistry to let mksig know the full address of where it lives in the computer (is that what you're asking?)

As for the auto_update, thanks boss. :p That's a great idea you came up with, I was looking though the code and thought, "wow, that's a great application of how Perl thinks." I was going to put a checkbox saying "check for updates at startup". I think I understand what you said in the comments, Perl compiles once and that's it until it's run again?
I see your thinking, and it does seem like a better way. It rubs me the wrong way a little not to specify an absolute path, but using the windows registry rubs me the wrong way more. I'll just change $dir to "" (the empty string) for windows, which should solve the problem without screwing things up much. Note that this means that windows users will need to put mksig.pl in the dir where everything else lives, if they haven't already.

The update is is v.68, which is up now.
Haven't looked at why yet, but here's what I'm getting with v0.68:

Bah. It looks like I have to use absolute paths with windows. The newest version is .69 and undoes the previous version's change.
If you could figure out the registry, that's probably the best way to get this working like we want it to. Sorry for the breakage.


No need to be sorry, I'm working with you on the Windows end ;)

sig_gen.pl!!!! the .pl extension in line 30! That's why it wasn't working in v.68!!! Try the relative paths again, I bet you this time it'll work ;) :D :) (it worked when i added the .pl extension to mksig line30)
Last edited:
typo, boss ($extension versus $entension) :

#if we're in windows, just use the current dir
if ($^O =~ /win/i) {
  $dir = "";
  $extension = ".pl";

#now the following vars will be correct for either path style
$sig_gen  = $dir . "sig_gen" . $entension;
$config   = $dir . "mksig.conf";
$sig_log  = $dir . "sig.log";
$sig_file = $dir . "sig";
That'll teach me not to test what I post.
v.692 is up, and I made sure to test it a little this time.
No Prob :)0 Just in case you're curious about the task scheduling in Windows, here are some pictures to look at:

(WinXP) Start > All Programs > Accessories > System Tools > Scheduled Tasks. Here's what the window looks like.


Double click "Add Scheduled Task", then "Browse..." to mksig.pl:






Last edited:
JerMe, just a little note on your last screenie of the task scheduling properties. You need to have the duration to run set to more than how often the task is to run. Specifically, if you want to have the mksig run every three hours, then you would need to set the duration to 24 hours, so that it will repeat every 3 hours, within a 24 hour span.

Just a little FYI :)
Oops I didn't change that, thanks for pointing it out ;) I made a new task and was doing screen captures, didn't click the last OK. :)0
New version. Now mksig won't die if you use capital letters to limit the size of your log. It's .694 for those keeping track at home.
Edit: Thanks to TollHouseFrank for finding the bug and to JerMe for bringing it to my attention.
Last edited:
New version time!
The latest is v.7 and includes some code cleanup and a fix for those of you who like to enter values like "b" for your size instead of including a number.
Thanks again to JerMe for doing things I didn't expect him to.
stratcatprowlin said:
OK I downloaded and installed pearl then sig generator.Now what the heck do I do? help? winXP.

have you downloaded the mksig.pl file from the beginning of this thread yet? if not you could always use JerMe's gui sig generation installer, it should install all the files you need and help you get up and running fairly easily.
Find it here.

once you get the basic sig working, then if you really want to get into it you can modify your sig to do just about anything you want, PM me if you want some help.