• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

FEAR and Vista/Win7 solution

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

OnDborder

Senior Member
Joined
May 6, 2001
Location
HOT 'n Arizona
This is one of my favorites game series. Otherwise it wouldn't bother me. So..
I ,and others, had problems with awful performance with FEAR and Vista/Win7. http://www.ocforums.com/showthread.php?t=586443&highlight=fear
After a few minutes of gameplay the fps would drop to a crawl. Like a slideshow. I stopped even trying to play the game.
There was a theory that some of Logitech's mice were incompatible with the game. Causing the slideshow.
So when Win7 came out I gave it an other go with a Microsoft X8. Thinking it was a Vista/FEAR issue. Nope.. Same performance as Vista.. Bummer :(
So it was "shelved" again.
Then came Brando's thread. http://www.ocforums.com/showthread.php?t=625029
Fixed! :clap:
These are with the G9 and the "test" in FEAR run right after another.




 

theflash083

Member
Joined
Nov 15, 2009
im still really baffled by what is causing this.
What is it that the mouse interface could possibly do to cause this.
 

rainless

Old Member
Joined
Jul 20, 2006
This is one of my favorites game series. Otherwise it wouldn't bother me. So..
I ,and others, had problems with awful performance with FEAR and Vista/Win7. http://www.ocforums.com/showthread.php?t=586443&highlight=fear
After a few minutes of gameplay the fps would drop to a crawl. Like a slideshow. I stopped even trying to play the game.
There was a theory that some of Logitech's mice were incompatible with the game. Causing the slideshow.
So when Win7 came out I gave it an other go with a Microsoft X8. Thinking it was a Vista/FEAR issue. Nope.. Same performance as Vista.. Bummer :(
So it was "shelved" again.
Then came Brando's thread. http://www.ocforums.com/showthread.php?t=625029
Fixed! :clap:
These are with the G9 and the "test" in FEAR run right after another.

This reminds me that I never did finish FEAR because of some weird bug where it would just FREEZE after my character was killed (at the part where you normally press a button to reload the last check point.)

It didn't do it all the time (which was the annoying part) it did it RANDOMLY... like at the worst possible point in the game.

Very frustrating.

But now ALL my hardware is new since then. So I'm wondering if it will finally work now...
 

Aktunka

Member
Joined
Mar 4, 2003
Location
Portland, OR
That is very strange. I am on Vista Ultimate 64 with a Logitech G7 and recently played through FEAR again. I didn't experience any sort of problem with big slowdowns like that at all. Come to think of it, when FEAR first came out I never had a problem either but still had a Logitech mouse then as well. Well, hope that it works out better with that other mouse then :)
 
OP
OnDborder

OnDborder

Senior Member
Joined
May 6, 2001
Location
HOT 'n Arizona
On my original post, I was on Vista Ultimate and using a g9 mouse.
I don't know why the issue but I know that I can play the game with no problems now with this Trooper mouse on Win7 64.