• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

folding question

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.


Dec 30, 2003
Canada-Alberta-St. Paul
I have recently (4 days ago) started folding for a oranization but iv had it on like 16 hours each day and ive only done 120/400

why is going so slow when my frined start when i had 50 and is already at like 350

I know It depends on your computer but mine should be up to the task

p4 1.6 ghz
256 mb ram
64 mb graphics
Are you using the -advmethods and -forceasm flags? Has it been running all the time? Could you post the FAHLog.txt file here for us?
Sounds like you're folding a tinker core. Add the -advmethods flag and you should start seeing gromacs which will help out alot. Also, are you sure you're still on the same unit? Maybe you finished the first one and are up to 120 on the second unit.
LOL I dont under stand one thing you guys said but here are my logs (I think they are the ones you are requesting)

o and its still the first unit


  • fahlog.txt
    43.1 KB · Views: 66

This thread will explain it. Basically, you should edit the shortcut that starts your folding client so that you pass an optional flag to the program that will direct it to function in a slightly different way.


This flag will make folding@home select a different type of work units, work units that fold 3x faster than the standard type when run on a modern CPU (with SSE instructions).

You will fold so much faster after this quick little edit, and then restart your folding client with the modified shortcut. Once the current work unit is finished, the change will take effect.
cool thank you ill let you guys know how it goes after this wu thingy it will probley be done on moday :/

or should i delete this work unit and put in those shortcut thingys and then start it all over again?

o but one more thing I don't use a ico to start it I just restart my computer and it runs automatically

so where would I put the

-advmethods -forceasm things in my case?
There's no need to delete the current work unit.

Just close F@H, edit the shortcut that starts it, then restart it.

If it's set to start automatically with windows, you'll want to edit the shortcut in your startup folder too.

C:\Documents and Settings\All Users\Programs\Startup\Folding@Home
ok cool i just did that its at 124 right now im gonna go shower and see its improvements after words

I think im gonna like it at these forums you guys respond fast :D
It will have to get all the way to 400 and start a new work unit before youwill see the difference. Afterwards, your work units will have only 100 frames instead of 400, and will fold in less than a day.

PS. Welcome to the forums!!
There are 2 cores that do the processing in F@H- core 78 is the gromacs based core, while core 65 is the older tinker core. Each is used to process a different type of work unit as the processing is performed via a different method by each core.

The gromacs core can take advantage of SSE and 3dnow instructions, so CPU's that have those instruction sets will get a significant boost to processing time. Running gromacs on a CPU without those instruction sets will go at about the same pace as running the tinker core.

So tinker and gromacs fold at the same speed on old CPU's, but on most P3's and Celerons, all P4's, Athlon's, Opterons, FX's, and Durons, gromacs will fold faster because it can use either 3dnow or SSE to boost processing performance.

Old athlons (slot 7 and Thunderbirds), and old (spitfire core Durons) only have 3dnow, which does not offer nearly as much boost as SSE does.
Is 3dnow related to the -advmethods tag? The reason I ask is that my main rig has EMIII and I selected -advmethods, but in the log it shows 3dnow but not advmethods. My secondary rig is an old pIII 450 and it shows sse, I haven't put it on EMIII yet.

<edit> Sorry to hijack the thread, but it seemed like a general knowledge thing going on here. :p
-advmethods just makes it so you're more inclined to get the beta proteins before they're 100% stable. AMD's get the 3DNow! boost by default as far as I know.
Right, -advmethods steers you towards getting the gromacs work units.

3.xx clients

-forceasm forces SSE when used on a machine with an SSE-capable AMD CPU. Also, it will force SSE on even if your folding client was previously exited with an error.

4.0 client

-forcesse forces SSE to be used when used on a machine with an SSE-capable AMD CPU. Also, it will force SSE on even if your folding client was previously exited with an error.

-forceasm forces 3dNow! to be used when used on a machine with an 3dnow-capable AMD CPU. Also, it will force 3dNow! on even if your folding client was previously exited with an error.

As you can see, the latest 4.0 folding client is a little different than the 3.xx series.

For AMD CPU's you should use -advmethods -forcesse if using the 4.0 client. If using an Intel CPU and the 4.0 client, all you should need is -advmethods. If using an older 3.xx client, you should use -advmethods -forceasm.
hm,mm that was werid my folding thing deleted the wu i was on weried cause i was outa 200/400 (finally)

so now i started a new one I have those tages in the target (-advmethods -forceasm) and I have 0/250 so it should got 3times faster right?
You should use -forcesse instead of -forceasm. -forceasm was for the old 3.xx client. But the current folding client (4.0) uses the flags a little differently.

All you need is -advmethods on Intel CPU's. On AMD CPU's, you should use -forcesse as well.
ok so I should just delete the force one??

ok and one more thing you said "Afterwards, your work units will have only 100 frames instead of 400"

is that ok that I hae 250 or did something go wrong

also im going ALOT faster :D
Sounds like you've got it set alright. And actually, the new 4.0 client can now set frame size (as an interval in minutes between checkpoints), so the number of frames can vary depeding on how often you are creating checkpoints. Default setting is to checkpoint every 15 minutes.

If you examine your log file (FAHlog.txt) you can see if 3dnow or SSE is being used. It will say

SSE boost ok

or 3dnow boost ok

right around the first frame listed.

Like this:

[16:56:02] Project: 1025 (Run 0, Clone 99, Gen 13)
[16:56:03] Assembly optimizations on if available.
[16:56:03] Entering M.D.
[16:56:10] Protein: p1025_FSunf_273_GS
[16:56:10] Writing local files
[16:56:10] Extra SSE boost OK.
[16:56:10] Writing local files
[16:56:13] Completed 0 out of 2500000 steps (0)
[17:36:15] Writing local files
[17:36:18] Completed 25000 out of 2500000 steps (1)
[18:16:21] Writing local files