• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Forceing a refresh rate?

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

lemings

Member
Joined
Oct 10, 2005
Location
Texas
I just updated to Ubuntu 9.10 for the soundcard support (Xonar STX)... anywho... I updated my Nvidia drivers and my resolution is supported right away (1680x1050, it is a Dell 2209WA), but my refresh rate is locked in at 60hz, when I know the monitor can do 75hz. I tried editing my xorg.conf but it is for the most part... whiped out... as displayed below.

Code:
Section "Screen"
	Identifier	"Default Screen"
	DefaultDepth	24
EndSection

Section "Module"
	Load	"glx"
EndSection

Section "Device"
	Identifier	"Default Device"
	Driver	"nvidia"
	Option	"NoLogo"	"True"
EndSection

That is my whole config :-/ so am I doing something wrong here or am I just overlooking something? Even when I go to save the config through the nvidia panel, it says "failed to parse existing X config file"
 

Stratus_ss

Overclockix Snake Charming Senior, Alt OS Content
Joined
Jan 24, 2006
Location
Ontario Canada
try entering these

Code:
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Keep in mind this was something I specified for my monitor but adjusting the values to suite your needs should do the trick

This is what I have for my LCD TV
Code:
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "PRI"
    HorizSync       30.0 - 80.0
    VertRefresh     48.0 - 85.0
EndSection
 
OP
lemings

lemings

Member
Joined
Oct 10, 2005
Location
Texas
Just tried that with

Code:
Section "Screen"
	Identifier	"Default Screen"
	DefaultDepth	24
EndSection

Section "Module"
	Load	"glx"
EndSection

Section "Device"
	Identifier	"Default Device"
	Driver	"nvidia"
	Option	"NoLogo"	"True"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Dell"
    ModelName      "2209WA"
    HorizSync       32.0
    VertRefresh     75.0
EndSection

And still the 60hz is the only option showing.
 

Stratus_ss

Overclockix Snake Charming Senior, Alt OS Content
Joined
Jan 24, 2006
Location
Ontario Canada
I guess you could file a bug, to be honest I had problems with 9.10 and reverted within a day. Sometimes the latest and greatest changes the way something works and it takes a while to figure out what is now doing what

(see Grub2)

Unfortunately, I can only help generally now since I dont have a 9.1 install

try this
Code:
SubSection "Display"
	Depth		24
	Modes		"1280x1024_60" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection

Where the _60 is your desired refresh rate
 
OP
lemings

lemings

Member
Joined
Oct 10, 2005
Location
Texas
Hmm tried that as well, no results :-/. The thing is, I actually had this same issue on 9.04 and I just reverted back to windows being that I couldn't work that out... and my soundcard wasn't supported at the time.
 

Stratus_ss

Overclockix Snake Charming Senior, Alt OS Content
Joined
Jan 24, 2006
Location
Ontario Canada
any particular reason you have to get your monitor refresh rate up?
which version of the nvidia driver are you using and where did you get it? from nvidia's website?
 
OP
lemings

lemings

Member
Joined
Oct 10, 2005
Location
Texas
I would like to have it at 75hz because at 60hz it tends to tear whenever watching a movie and the scene is "fast paced". I just used the nvidia driver that ubuntu said I needed from "hardware drivers".
 

Stratus_ss

Overclockix Snake Charming Senior, Alt OS Content
Joined
Jan 24, 2006
Location
Ontario Canada
I would recommend uninstalling those and installing the ones right from NVIDIA. Very important that you uninstall the ones from Ubuntu first.

Nvidia drivers from their site do differ from the ones in the repositories

http://www.nvidia.com/Download/index.aspx?lang=en-us

if you need help installing them just let me know. Its simple but different then what you may be used to
 

Stratus_ss

Overclockix Snake Charming Senior, Alt OS Content
Joined
Jan 24, 2006
Location
Ontario Canada
Did you run the nvidia control panel as root? If you don't you won't be able to save.

Code:
sudo nvidia-settings

its a good suggestion, but if they are editing the Xorg.conf they dont have to work about the Nvidia settings

I still suspect that its related to the Ubuntu drivers, but who knows
 
OP
lemings

lemings

Member
Joined
Oct 10, 2005
Location
Texas
I uninstalled and installed the one from their site. I came up with this now for my xorg.conf.... looks better at least. I'm stuck as to where to add the subsection to put the mode at.

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  ([email protected])  Tue Oct 20 21:00:15 PDT 2009

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  ([email protected])  Tue Oct 20 21:01:12 PDT 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL 2209WA"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 285"
EndSection

Section "Screen"

# Removed Option "TwinView" "0"
# Removed Option "metamodes" "DFP-1: nvidia-auto-select +0+0"
# Removed Option "metamodes" "DFP-0: nvidia-auto-select +1680+0, DFP-1: nvidia-auto-select +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DFP-0: 1680x1050 +1680+0, DFP-1: 1680x1050 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
 

Stratus_ss

Overclockix Snake Charming Senior, Alt OS Content
Joined
Jan 24, 2006
Location
Ontario Canada
I uninstalled and installed the one from their site. I came up with this now for my xorg.conf.... looks better at least. I'm stuck as to where to add the subsection to put the mode at.

Thats an easy one, its the very last subsection in your xorg.conf.

See where it says Subsection "Display"

trying putting this in its place
Code:
SubSection "Display"
	Depth		24
	Modes		"1280x1024_75" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
 
OP
lemings

lemings

Member
Joined
Oct 10, 2005
Location
Texas
Just checked it and it still is locked at 60hz :-/... I also added the 1680x1050_75 down below the depth in the xorg.conf and still no results.
 
OP
lemings

lemings

Member
Joined
Oct 10, 2005
Location
Texas
^I actually tried that before I posted here and it came up empty as well. Just for experimentation.... I set the mode to 60hz instead of Auto through the nvidia panel. It edited my xorg.confg with this change....

Code:
Section "Screen"

    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "[COLOR="Red"]DFP-0: 1680x1050_60 +1680+0, DFP-1: 1680x1050_60 +0+0; DFP-0: NULL, DFP-1: 1680x1050 +0+[/COLOR]0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

I would assume I could just change those to 75... but when I do that still no change.
 
OP
lemings

lemings

Member
Joined
Oct 10, 2005
Location
Texas
I did the ctrl alt +f1 and then did sudo /etc/init.d/gdm stop .... when I do that however it just gives me the message.... "Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the start(8) utility, e.g."

I don't know if that kills x or not... but I restart gdm and my gui comes back. Just to make sure though.... I logged out and logged back in and still same.
 

Sydney

Member
Joined
Sep 28, 2009
Location
Reykjavík, Iceland
I did the ctrl alt +f1 and then did sudo /etc/init.d/gdm stop .... when I do that however it just gives me the message.... "Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the start(8) utility, e.g."

I don't know if that kills x or not... but I restart gdm and my gui comes back. Just to make sure though.... I logged out and logged back in and still same.
On 9.10 you need to do

sudo service gdm restart
to restart gdm
 
OP
lemings

lemings

Member
Joined
Oct 10, 2005
Location
Texas
Just tried that with the added 1680x1050_75 in both the metamodes and also the mode. Nice to see the simplified the process of restarting X... but still didn't work. lol