• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

FPS difference

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Dpg3456

Member
Joined
Jul 31, 2016
Hello all,

Recently I was watching my brother play battlefield 4 on my computer while I watched the task manager and oc guru for the gpu. On the high preset, I am getting about 60fps while the cpu never got over 50% utilization and the gpu never got over 70%. On Ultra, I get about 45-50 fps while the cpu is at 53% and gpu hovered around 74%.

I have a 9590, gtx 980 and 32gbs of ram.

Only difference in quality was fps drop, which was quit noticeable. Shouldnt the usage go up on both the cpu and gpu when i changed the settings to ultra? But they didnt and the fps dropped. It seems that nothing is being bottle-necked? Any information will be helpful. Thanks for the help.

Edit: The resolution is 1080p and 60hz refresh rate.
 

Lochekey

Senior Pink Member
Joined
Sep 13, 2015
Were you seeing an even 50% cpu utilization across all 8 cores or were you seeing a 100% utilization across 4 cores resulting in a 50% overall utilization. If the second case was the scenario going to the higher preset is not going to show a higher cpu utilization as it is already maxed and thus why you are not getting good performance form the system.
 
OP
D

Dpg3456

Member
Joined
Jul 31, 2016
At ultra, the cpu was around 55% and cores were at: 48, 73, 66, 55, 69, 40, 59, 40. At High, 60% at: 56, 81, 68, 65, 76, 45, 72, 42. With same fps drop. I was just laying down on the railway watching the cores.

Is there a reason its not going full utilization? I took off the turbo and its running at 4.7 ghz. Would clocking it to 5 help?
 
Last edited:
OP
D

Dpg3456

Member
Joined
Jul 31, 2016
So i went into the bios and changed all the settings back to auto except for a few things, and i notice the clock go up and down but never passing 4.7, even though it should boost to 5. Any suggestions?
 

wingman99

Member
Joined
Dec 10, 2003
I lowed my CPU clock to 2.5GHz from 4.5GHz and the FPS was much lower however the CPU utilization stayed the same. So I don't go by utilization.
 
OP
D

Dpg3456

Member
Joined
Jul 31, 2016
So how do you judge it?

But it still wont turbo to 5.0ghz on its own. I enabled it in the bios and ran a benchmark but still no 5.0.

EDIT: I went into the bios, set it to turbo and set the turbo at 25, which set the target turbo clock speed to 5.0 and under a benchmark it still wont clock past 4.7. Ill post into the cpu sub forum, thanks for the help.

I still dont understand the major fps drop when going to ultra though.
 
Last edited: