• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Frustration with no ability to permanently disable hardware in Windows 10

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

trents

Senior Member
Joined
Dec 27, 2008
So this is frustrating to me and Microsoft should fix this. For instance, I have a Wifi and bluetooth adapter built into my motherboard and currently do not use either, though someday I might. To save resources (CPU cycles and memory) and eliminate the possibility of driver conflicts I can disable them in Device Manager but whenever I reboot the are enabled again. If I remove their drivers Windows will just find them again and install drivers.
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
Wi-Fi can be disabled from the taskbar IIRC. Same with BT. I cant say it's going to save much for cpu cycles leaving them enabled though.

Also, I know this is a workaround, but disable them from the bios. When you need them, turn it on again and they will be there functioning. :)
 

Alaric

New Member
Joined
Dec 4, 2011
Location
Satan's Colon, US
Satya Nadella is one of the most annoying people in the history of annoying people. The most insidious forms of evil manifest themselves in good intentions.

Is there any way to stop W10 Update from being allowed to install drivers? Or is that just a happy side effect of not having control over updates?
 

WhitehawkEQ

Premium Member
Joined
Dec 6, 2010
If I remove their drivers Windows will just find them again and install drivers.

You could always do this to stop windows from reinstalling the drivers. Just copy and paste to command window with admin privileges.

To disable
Code:
[cd /d "%Windir%\System32"
takeown /F MusNotification.exe
icacls MusNotification.exe /deny Everyone:(X)
takeown /F MusNotificationUx.exe
icacls MusNotificationUx.exe /deny Everyone:(X)
rem

To re-enable
Code:
cd /d "%Windir%\System32"
icacls MusNotification.exe /remove:d Everyone
icacls MusNotification.exe /grant Everyone:F
icacls MusNotification.exe /setowner "NT SERVICE\TrustedInstaller"
icacls MusNotification.exe /remove:g Everyone
icacls MusNotificationUx.exe /remove:d Everyone
icacls MusNotificationUx.exe /grant Everyone:F
icacls MusNotificationUx.exe /setowner "NT SERVICE\TrustedInstaller"
icacls MusNotificationUx.exe /remove:g Everyone
rem
 
Last edited:
OP
trents

trents

Senior Member
Joined
Dec 27, 2008
Wi-Fi can be disabled from the taskbar IIRC. Same with BT. I cant say it's going to save much for cpu cycles leaving them enabled though.

Also, I know this is a workaround, but disable them from the bios. When you need them, turn it on again and they will be there functioning. :)

Yes, thanks for the reminder. They're both disabled now. Put it on airplane mode.
 
OP
trents

trents

Senior Member
Joined
Dec 27, 2008
Satya Nadella is one of the most annoying people in the history of annoying people. The most insidious forms of evil manifest themselves in good intentions.

Is there any way to stop W10 Update from being allowed to install drivers? Or is that just a happy side effect of not having control over updates?

Not that I know of but I haven't tried WhiteHawk's method yet but that seems like the shotgun approach. There's a thread in this same section that claims Microsoft is adding the ability to disable driver updates for individual devices when the Spring 2020 Feature update comes out. But given Microsoft's history with these Feature updates, the Spring Feature update probably won't come until Fall 2020.

Actually, what prompted this current thread was more than wanting to disable BT and Wifi. I was lumping that together with a problem with what I'm about to describe. But it is not the same and ED's suggestions fixed the Wifi/BT thing. Read on.

I just built a mini ITX system with a used itx motherboard that I picked up off ebay. The board is the Intel DQ67EP (socket 1155) paired with a second generation i5. It works great but there is a flag in Device manager saying there is no device driver for an "Other" PCI device, which turns out to actually refer to a missing Management Engine driver for Windows 10. I looked high and low and tried this various ME drivers but none of them would install. Now, I don't think a missing ME driver will actually have any impact on the operation of the system practically speaking but it bugs me that there is this line item in Device Manager that has a flag. So here is my question:

Is there a way to permanently disable that device? Every time I reboot Windows finds it again and tries in vain to install a driver and the flag is back. I don't want to disable driver update altogether (as per WhiteHawk's method). There is an ME tab in bios but in order to access the options you need a password, which I don't have because this is a used board. Oh wait, there is a Security tab in bios also and when I go there it says the Supervisor Password has not been set. Would creating one give me access to the ME panel?
 
Last edited:

Alaric

New Member
Joined
Dec 4, 2011
Location
Satan's Colon, US
Uninstall it through Device Manager Driver tab in the Properties pop up. That should do it. If you ever want it "reinstalled" just select 'scan for hardware changes' from the Action button on the Device Manager menu bar. That's the Windows 7 procedure, though. It may work just like that in W10 but I don't know.
 
OP
trents

trents

Senior Member
Joined
Dec 27, 2008
No, it doesn't work that way in Windows 10, apparently. When you uninstall the device, you are just uninstalling the driver. The driver is the device as far as Windows 10 is concerned. With next boot-up, Windows detects new hardware and re-installs the driver. The only way to prevent that would be using WhiteHawk's method. But that would prevent all driver updates. Don't want that.

Anyway, for now it's a moot point as I updated the bios, did some more searching and found a Windows 7 ME driver that works in Windows 10.
 
Last edited:

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
No, it doesn't work that way in Windows 10, apparently. When you uninstall the device, you are just uninstalling the driver. The driver is the device as far as Windows 10 is concerned. With next boot-up, Windows detects new hardware and re-installs the driver. The only way to prevent that would be using WhiteHawk's method. But that would prevent all driver updates. Don't want that.
or... disable the WAN radio from the bios so windows doesnt recognize it in the first place. ;)

1. Disable the device in device manager.
2. Uninstall driver.
3. Reboot to bios, disable BT/WAN l, save and reboot.

Windows wont pick it up until you enable it from the bios.

You dont even have to uninstall or down it in device manager. Just disable it from the bios. Again, I know it isnt windows, but accomplishes the same goal with the additional cost of a reboot. ;)