• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

G.Skill DDR5-32GB-6400-CL-32Trident Z5

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.


Jul 2, 2022
Hi guys! I just built a new PC with G.Skill DDR5-32GB-6400-CL-32Trident Z5, I9 12900KS and Motherboard: ROG STRIX Z690-F GAMING WIFI (BIOS Version 1505). First time I tried to boot the PC with XMP 2 and it didnt work, after I went with XMP 1 it worked, I installed windows 11 and I tried to make some tests with memtest 64 and I got everytime "test failed" + Blue screen with this error: Kernel Security Check Failure, after this I did all my driver updates, windows updates and I tried to test on memetest 64 with XMP 1, XMP 2, AUTO and everytime I got the same problem. I installed windows 10 and the same problem is happening with XMP 2, BUT with XMP 1 I get no fails in memtest 64. So after I saw that I am not getting any errors with XMP 1 I decided to make a test on AIDA 64...and sometimes the test fails "Hardware failure detected" but sometimes it s good...And I dont what is happening I fell like something it s not ok but I dont know what. Do you have any advice, any ideas on how to resolve it? Do I need to make other changes? Because I really want to use windows 11 and I dont know what to do or what changes to make. Thanks in advance!
6400 is at the top end of plug and play. Most z690 mobos are good to 6200-6400.

Did you test at default/4800? Do the sticks fail there? If so they are bad and return them. Otherwise, I'll ask....does it work for you in your uses??
Well I tried them at default in windows 11 and in memtest 64 sometimes was ok sometimes I got some fails + Blue screen with Kernel Security Check Failure. In windows 10 with XMP 1 I am not getting fails and blue screens in memtest 64, sometimes I am getting hardware failure in AIDA 64, but everyhting works fine in my uses like editing, gaming, no errors. But I dont know I am a bit scared because they might have some problems...or I dont know to make some changes.

Also today I was looking in the Event Viewer and I saw that I have some warnings: Event 219 kernel-pnp, Event 10016 DistributedCOM, Event 37 kernel-processor-power (Microsoft-Windows-Kernel-Processor-Power) - this one is for processor 16 to 23 and Event 27 e2fexpress (This idk why I am getting because my Internet works great).

And I am wondering if I will upgrade to windows 11 again if I ll get the same problems...what s your advice?
Also I ran a windows memory diagnostic and everything was fine so I guess is some software problems
Do you think I am safe to try a clean windows 11 installation? Also Idk what are these warnings Event 219 kernel-pnp, Event 10016 DistributedCOM, Event 37 kernel-processor-power (Microsoft-Windows-Kernel-Processor-Power) - this one is for processor 16 to 23 and Event 27 e2fexpress (This idk why I am getting because my Internet works great).
XMP I - optimized for performance, XMP II - optimized for compatibility. Both these profiles are not exactly the same as the default RAM XMP profile. In theory XMP II should cause less problems but is slightly slower. In real, as you see, it may not work.
Be sure that you use 2/4 memory slots counting from the CPU socket side.
Check manual settings - RAM clock, main timings and voltages the same as in the XMP, everything else at auto.
If 6400 will be still causing problems then check 6200 and XMP or manual (as described above) settings.
If you won't make it run at 6200-6400, then you can try something like 6000 CL28/30.
If your RAM is throwing errors during longer stability tests, then check if it's not overheating. Typically, these modules are safe up to ~100°C, but at higher frequencies are losing stability above 60°C (higher like over 6000).

I was checking this kit only on 2-slot motherboards and it could run without issues at 6800+. However, 2-slot motherboards are rated at significantly higher memory clock, so can't compare that directly. It didn't work on Gigabyte Z690 Master at 6400 but it's another story.
Hi. Yea I am using the slots that you mention. Now I am running with XMP 1 at 6400 with CL 32, on windows 11, seems that is working fine now I dont know why.

But I am still getting these warnings: Event 219 kernel-pnp, Event 10016 DistributedCOM, Event 37 kernel-processor-power (Microsoft-Windows-Kernel-Processor-Power) - this one is for processor 16 to 23, Event 27 e2fexpress (This idk why I am getting because my Internet works great) and Event 17 WHEA-logger. I just spoke with the Microsoft Chat Support and they told me that it's a driver compatibility problem and that I should wait for a new update to solve my problems, also I ran a Windows Memory Diagnostic and all was good. Also they told me that these warnings are not affecting the power of my PC, it s just a driver compatibility problem.
UPDATE: i just ran some memtest 64 on windows11 sometimes it s saying this Memory locking failed (but it says “no error detected) sometimes it works great. Also I ran some AIDA 64 test and first problem is CPU throttling - overheating detected after some minutes - hardware failure. I have a CPU COOLER: Corsair ICUE H170i ELITE Display LCD. So all the error can be from the CPU overheating? The thermal paste can be bad or CPU placement is bad?

In AIDA64 options disable AVX-512 (and maybe AVX too). It should help with CPU temps. Also, for RAM tests you can use only memory and cache tests. CPU+FPU are not important during RAM tests.

If you get overheating + hardware failure then I would check the cooler. Thermal throttling is typical for new CPUs with mentioned AVX tests as most coolers can barely keep it below the throttling point (95-100°C for new CPUs). However, the test shouldn't stop even when the CPU runs with throttling. When are hardware errors then the temperature is way too high, BIOS settings are incorrect or there is a hardware failure.

WHEA errors usually suggest problems with hardware/settings/overclocking/overheating. Run hwinfo64 only with sensors (it's free and can download a portable version) and check what is at the end of the table. It should suggest what type of errors you get or what component is causing them.
Ok so I run hwinfo64 like you said and at the end of the table it says "0 Hardware Problems). I still have these warnings that I told in the previous replies. I ll put an image with the error I am getting JUST when I am using XMP 2. With XMP 1/Auto I it s working nice.

Maybe just back to full auto/default settings and try step by step like stability test/daily usage for 1-2 days, all is fine then add something. I see there are some weird issues and Windows errors suggest various things (and are changing).
When hwinfo64 is not showing errors then there are no general hardware problems that OS can correct (there are corrected errors and the list is taken from the OS logs), so I guess it's more matter of compatibility (some devices or drivers are not showing errors in diagnostic programs, they just cause blue screens or instant OS restarts).
So a quick update: I had to update some Network and WiFi drivers + I had to disable the PCI Express Native Power Management in BIOS. I am not getting WHEA-Logger Event 17 anymore, with XMP 1 everything is fine I dont get any BOSD + in all games with max settings + 2 monitors + chrome and discord in the background my CPU stays around 50-55 temperatures and my GPU around 60-65 with a hotspot around 69-71.

Also with full default settings in BIOS -> no overheating/hardware failure in AIDA 64 stability test (with default settings), but I ll use XMP 1 since I want to get the full power of my DDR5 and CPU.

Kernel Event 37 and 219 and from what I understand it s caused by SpeedStep Technology (right now it s enabled), but I dont think it's ok to disable it. Also should I change Core Parcking to 100% (to enable all the cores)? right now it s set to 5% and I saw some tutorials that are saying it s good to enable all of them.
Ok got it. And I have 2 more questions so you know my Build G.Skill DDR5-32GB-6400-CL-32Trident Z5, I9 12900KS, 3090ti, SSD samsung 980 pro 2TB + 4 TB HDD WD. I installed win 11 on the SSD and I optimized as much as I could my PC and my boot time is 22.8 sec (keep in mind is brand new PC i have few programs), and on my old PC is like 12 sec. What can I do because it s a bit frustrating :)))) Also should I split the 2TB of SSD in 1tb for windows and 1 tb for other applications?
Dragos, you can create a signature with your hardware in it... this way we all see it with every post and you don't have to retype it. ;)

W11 takes a bit longer for me to boot too. I honestly don't care as I boot once day, really. 22 seconds is nothing (I understand it's more than 12).

As far as partitioning your HDD, I do. I leave around 300GB for OS and the rest for games. This way if I need to blow Windows out of the water I don't need to DL the games again.