• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

GA-H55M-S2V Windows 10 issue

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Time-Bandit

Member
Joined
Jul 30, 2014
Hi all,

Installed Windows 10 on an older machine using GA-H55M-S2V motherboard now it was previously on Windows 7 and my trick is normally to teather an Android phone so it can get internet access to update the drivers in this case once I am on windows 10 this doesn't work. On the website for this board there is no mention of Windows 10 drivers is it at all possible to get the internet working as I have tried to use drivers from that website and I have had no luck. When I google my motherboard and win 10 drivers there is another website that has drivers but again I have installed those and still no luck. Looking in device manager there is a pci simple communications controller that has a ? next to it. I googled the devid that I got from device manager and it points me in the direction of the chipset any ideas on which I can use to get the internet going on this?

I also noted that the realtek device was under hidden and when I checked out the details on it, it said that it may have been asleep/shutdown or something i removed the driver in an attempt a reboot might get it going again but now its gone completely.

Also checked the BIOS settings and can't see anything in there that would be keeping the Realtek device in check like its not working. So I am really stumped on this one.

Any help on this would be really great.

Below are the links I am talking about above (on rev 1.4 and bios is updated also)

https://www.gigabyte.com/Motherboard/GA-H55M-S2V-rev-14#ov

http://www.driverscape.com/manufacturers/gigabyte/laptops-desktops/h55m-s2v/8701

Cheers,

Bandit
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
It would be incredibly helpful for anyone who comes across this thread to see what the actual solution was...

...please add that and mark the thread as SOLVED. :)