• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Gigabyte 980ti No 2nd Display Port

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Hishman

Registered
Joined
Nov 15, 2013
So i've had a triple minitor setup i ran on my r9 270x for a while then i got a 980ti and didnt bother to set up the other two monitors for desk space issues. However i recently decided to set up my monitors using HDMI, DVI, DVI ports on the card. The cables are DVI going into the monitor. Ive had a lot of issues getting the monitors to work. The hdmi port works fine and my monitor goes to 1080p and the computer detects it in control panel as dell 2340m. The same is true for the DVI port directly below the HDMI port. If i have both plugged in i can set them up in a display group. The problem is with the 2nd DVI port. Ive tried many combinations of on/off unplug plug etc. This port will display the monitor in a very low resolution like before u get drivers installed. This monitor overides the other monitors and they will not display while this one is plugged in. Also any device plugged in this DVI port is not detected in the control panel.

Heres the kicker. When i go to the nvidia control panel and look a the configure surround/phys-x the 2nd DVI port literally doesnt even show up. There are just three display ports, one hdmi, and one DVI.

Anyone have any ideas?

Here is a thread where it seems others have had porblems: https://forums.geforce.com/default/...ti-not-supporting-my-3-monitors-please-help-/