• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Good News for Windows 7 users

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

JLK03F150

What have I done! Member
Joined
May 17, 2005
Location
Georgia
Wish I'd found this rollup on Sunday. I did a Win7 reinstall on my notebook and WU refused to work for me. It was checking for updates for more than 24 hours. I'm using WSUS_Offline now & it has been somewhat working, but still not finished installing 200+ updates.

Tried to download the not-SP2 with FF, telling me I need to use IE6 or better.
 
OP
Alaric

Alaric

New Member
Joined
Dec 4, 2011
Location
Satan's Colon, US
I've had nothing but problems with WU since my reinstall. I ended up with a third party tool. I've run more WU repair programs than I can count, at least 3 from M$, all to no end. Action Center can't download a fix for a driver issue, either. It's like AMD's driver crew is in charge of WU. LOL

Tried to download the not-SP2 with FF, telling me I need to use IE6 or better.

Yeah, that's annoying but you can run IE just for that and uninstall it if you want.
 

MattNo5ss

5up3r m0d3r4t0r
Joined
Aug 11, 2008
Direct download links for prerequisite (KB3020369):

x86
x64

Direct download links for "Definitely Not SP2" (KB3125574):

x86
x64

No IE required :thup:
 
Last edited:

JLK03F150

What have I done! Member
Joined
May 17, 2005
Location
Georgia
Nice! I still have a Vista folder I need to install Win7 Pro, then to Win10 to get the key upgraded.
Thanks Matt