• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

GPU folding on Linux

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

HankB

Member
Joined
Jan 27, 2011
Location
Beautiful Sunny Winfield
I have a couple of questions.

First, I recall tweaking the SETI GPU application to run two instances. This is on a GeForce GTX 460 (Fermi) with 1GB RAM. Is there a similar setting for FAH? Should I use that? (I'm also driving two 1920x1200 monitors with this card.)

Second, should I be able to fold using my laptop GPU? It's a GeForce GTX 860M (Maxwell, I think.) I have the same drivers installed on both - 340.96 I've tried to add the GPU slot but FAH reports "no available GPUs." Probably not a big deal as a laptop is not an optimum folding machine. If I load this one too much it just shuts down. I'm not overly impressed by the Lenovo Y50.

Third (OK, a few questions) is this a good driver version? ISTR that there was a big performance difference with some driver versions and the newer ones were not necessarily better.

Thanks!
 

HayesK

Member
Joined
Oct 11, 2008
Fermi and Kepler need to use driver 304 in Linux. Core_17 Linux version was never updated with the fix for the slowdown that occurs with drivers later than 327. (Windows core_17 was updated). Maxwell runs best with Linux driver 346.96.
 

caddi daddi

Godzilla to ant hills
Joined
Jan 10, 2012
as for not finding the gpu, you need to go config/expert, back in there you will find where the cpu, the gpu and all that is listed.
you will find that gpu is noted as false, change this to true and it should pick up the card on restart.
I would go into more detail but I don't have a Linux rig in the house right now.
good luck.
 
OP
HankB

HankB

Member
Joined
Jan 27, 2011
Location
Beautiful Sunny Winfield
Fermi and Kepler need to use driver 304 in Linux. Core_17 Linux version was never updated with the fix for the slowdown that occurs with drivers later than 327. (Windows core_17 was updated). Maxwell runs best with Linux driver 346.96.

I reverted the drivers to 304.131. Now the GPU slot is not folding. I removed it and added it back in. For a while it switches between "Running" and "Ready" before settling on "Failed." :(

It looks like I'm getting Core_18 GPU work and Core_21 for the CPU.

I see the following in the log:
Code:
23:18:36:WU01:FS01:0x18:ERROR:exception: Bad platformId size.
23:18:36:WU01:FS01:0x18:Saving result file logfile_01.txt
23:18:36:WU01:FS01:0x18:Saving result file log.txt
23:18:36:WU01:FS01:0x18:[email protected] Core Shutdown: BAD_WORK_UNIT
23:18:37:WARNING:WU01:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
23:18:37:WU01:FS01:Sending unit results: id:01 state:SEND error:FAULTY project:9145 run:16 clone:1 gen:107 core:0x18 u

More complete log following ading the GPU slot.
Code:
23:18:04:Saving configuration to /etc/fahclient/config.xml
23:18:04:<config>
23:18:04:  <!-- Client Control -->
23:18:04:  <fold-anon v='true'/>
23:18:04:
23:18:04:  <!-- Folding Slot Configuration -->
23:18:04:  <gpu v='false'/>
23:18:04:
23:18:04:  <!-- Network -->
23:18:04:  <proxy v=':8080'/>
23:18:04:
23:18:04:  <!-- User Information -->
23:18:04:  <passkey v='********************************'/>
23:18:04:  <team v='32'/>
23:18:04:  <user v='HankB'/>
23:18:04:
23:18:04:  <!-- Folding Slots -->
23:18:04:  <slot id='0' type='CPU'/>
23:18:04:  <slot id='1' type='GPU'/>
23:18:04:</config>
23:18:04:WU01:FS01:0x17:*********************** Log Started 2016-01-04T23:18:03Z ***********************
23:18:04:WU01:FS01:0x17:Project: 10469 (Run 0, Clone 252, Gen 178)
23:18:04:WU01:FS01:0x17:Unit: 0x00000127538b3db9538f3ef17b0f4128
23:18:04:WU01:FS01:0x17:CPU: 0x00000000000000000000000000000000
23:18:04:WU01:FS01:0x17:Machine: 1
23:18:04:WU01:FS01:0x17:Reading tar file state.xml
23:18:04:WU01:FS01:0x17:Reading tar file system.xml
23:18:04:WU01:FS01:0x17:Reading tar file integrator.xml
23:18:04:WU01:FS01:0x17:Reading tar file core.xml
23:18:04:WU01:FS01:0x17:Digital signatures verified
23:18:04:WU01:FS01:0x17:ERROR:exception: Bad platformId size.
23:18:04:WU01:FS01:0x17:Saving result file logfile_01.txt
23:18:04:WU01:FS01:0x17:Saving result file log.txt
23:18:04:WU01:FS01:0x17:[email protected] Core Shutdown: BAD_WORK_UNIT
23:18:04:WARNING:WU01:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
23:18:04:WU01:FS01:Sending unit results: id:01 state:SEND error:FAULTY project:10469 run:0 clone:252 gen:178 core:0x17 unit:0x00000127538b3db9538f3ef17b0f4128
23:18:04:WU01:FS01:Uploading 1.85KiB to 140.163.4.233
23:18:04:WU01:FS01:Connecting to 140.163.4.233:8080
23:18:04:WU01:FS01:Upload complete
23:18:04:WU01:FS01:Server responded WORK_ACK (400)
23:18:04:WU01:FS01:Cleaning up
23:18:04:WU00:FS01:Connecting to 171.67.108.45:80
23:18:05:WU00:FS01:Assigned to work server 171.67.108.159
23:18:05:WU00:FS01:Requesting new work unit for slot 01: READY gpu:0:GF104 [GeForce GTX 460] from 171.67.108.159
23:18:05:WU00:FS01:Connecting to 171.67.108.159:8080
23:18:05:WU00:FS01:Downloading 19.94MiB
23:18:11:WU00:FS01:Download 40.75%
23:18:17:WU00:FS01:Download 77.73%
23:18:20:WU00:FS01:Download complete
23:18:20:WU00:FS01:Received Unit: id:00 state:DOWNLOAD error:NO_ERROR project:9152 run:20 clone:18 gen:19 core:0x18 unit:0x00000016ab436c9f56623c602f2d71a4
23:18:20:WU00:FS01:Starting
23:18:20:WU00:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_18.fah/FahCore_18 -dir 00 -suffix 01 -version 704 -lifeline 1606 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
23:18:20:WU00:FS01:Started FahCore on PID 5089
23:18:20:WU00:FS01:Core PID:5093
23:18:20:WU00:FS01:FahCore 0x18 started
23:18:21:WARNING:WU00:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
23:18:21:WU00:FS01:Sending unit results: id:00 state:SEND error:FAULTY project:9152 run:20 clone:18 gen:19 core:0x18 unit:0x00000016ab436c9f56623c602f2d71a4
23:18:21:WU00:FS01:Uploading 5.50KiB to 171.67.108.159
23:18:21:WU00:FS01:Connecting to 171.67.108.159:8080
23:18:21:WU00:FS01:Upload complete
23:18:21:WU00:FS01:Server responded WORK_ACK (400)
23:18:21:WU00:FS01:Cleaning up
23:18:21:WU01:FS01:Connecting to 171.67.108.45:80
23:18:22:WU01:FS01:Assigned to work server 140.163.4.234
23:18:22:WU01:FS01:Requesting new work unit for slot 01: READY gpu:0:GF104 [GeForce GTX 460] from 140.163.4.234
23:18:22:WU01:FS01:Connecting to 140.163.4.234:8080
23:18:22:WU01:FS01:Downloading 3.27MiB
23:18:23:WU01:FS01:Download complete
23:18:23:WU01:FS01:Received Unit: id:01 state:DOWNLOAD error:NO_ERROR project:10478 run:1 clone:128 gen:197 core:0x18 unit:0x000000f7538b3dba548f6fec3f2b94d1
23:18:23:WU01:FS01:Starting
23:18:23:WU01:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_18.fah/FahCore_18 -dir 01 -suffix 01 -version 704 -lifeline 1606 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
23:18:23:WU01:FS01:Started FahCore on PID 5096
23:18:23:WU01:FS01:Core PID:5100
23:18:23:WU01:FS01:FahCore 0x18 started
23:18:23:WU01:FS01:0x18:*********************** Log Started 2016-01-04T23:18:23Z ***********************
23:18:23:WU01:FS01:0x18:Project: 10478 (Run 1, Clone 128, Gen 197)
23:18:23:WU01:FS01:0x18:Unit: 0x000000f7538b3dba548f6fec3f2b94d1
23:18:23:WU01:FS01:0x18:CPU: 0x00000000000000000000000000000000
23:18:23:WU01:FS01:0x18:Machine: 1
23:18:23:WU01:FS01:0x18:Reading tar file state.xml
23:18:23:WU01:FS01:0x18:Reading tar file system.xml
23:18:23:WU01:FS01:0x18:Reading tar file integrator.xml
23:18:23:WU01:FS01:0x18:Reading tar file core.xml
23:18:23:WU01:FS01:0x18:Digital signatures verified
23:18:23:WU01:FS01:0x18:[email protected] GPU core18
23:18:23:WU01:FS01:0x18:Version 0.0.4
23:18:23:WU01:FS01:0x18:ERROR:exception: Bad platformId size.
23:18:23:WU01:FS01:0x18:Saving result file logfile_01.txt
23:18:23:WU01:FS01:0x18:Saving result file log.txt
23:18:23:WU01:FS01:0x18:[email protected] Core Shutdown: BAD_WORK_UNIT
23:18:24:WARNING:WU01:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
23:18:24:WU01:FS01:Sending unit results: id:01 state:SEND error:FAULTY project:10478 run:1 clone:128 gen:197 core:0x18 unit:0x000000f7538b3dba548f6fec3f2b94d1
23:18:24:WU01:FS01:Uploading 1.91KiB to 140.163.4.234
23:18:24:WU01:FS01:Connecting to 140.163.4.234:8080
23:18:24:WU01:FS01:Upload complete
23:18:24:WU01:FS01:Server responded WORK_ACK (400)
23:18:24:WU01:FS01:Cleaning up
23:18:24:WU00:FS01:Connecting to 171.67.108.45:80
23:18:25:WU00:FS01:Assigned to work server 140.163.4.245
23:18:25:WU00:FS01:Requesting new work unit for slot 01: READY gpu:0:GF104 [GeForce GTX 460] from 140.163.4.245
23:18:25:WU00:FS01:Connecting to 140.163.4.245:8080
23:18:25:WU00:FS01:Downloading 5.13MiB
23:18:26:WU00:FS01:Download complete
23:18:27:WU00:FS01:Received Unit: id:00 state:DOWNLOAD error:NO_ERROR project:10495 run:12 clone:8 gen:92 core:0x21 unit:0x000000828ca304f555d34df2371a474d
23:18:27:WU00:FS01:Starting
23:18:27:WU00:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21 -dir 00 -suffix 01 -version 704 -lifeline 1606 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
23:18:27:WU00:FS01:Started FahCore on PID 5103
23:18:27:WU00:FS01:Core PID:5107
23:18:27:WU00:FS01:FahCore 0x21 started
23:18:27:WU00:FS01:0x21:*********************** Log Started 2016-01-04T23:18:27Z ***********************
23:18:27:WU00:FS01:0x21:Project: 10495 (Run 12, Clone 8, Gen 92)
23:18:27:WU00:FS01:0x21:Unit: 0x000000828ca304f555d34df2371a474d
23:18:27:WU00:FS01:0x21:CPU: 0x00000000000000000000000000000000
23:18:27:WU00:FS01:0x21:Machine: 1
23:18:27:WU00:FS01:0x21:Reading tar file core.xml
23:18:27:WU00:FS01:0x21:Reading tar file system.xml
23:18:27:WU00:FS01:0x21:Reading tar file integrator.xml
23:18:27:WU00:FS01:0x21:Reading tar file state.xml
23:18:27:WU00:FS01:0x21:Digital signatures verified
23:18:27:WU00:FS01:0x21:[email protected] GPU Core21 [email protected] Core
23:18:27:WU00:FS01:0x21:Version 0.0.17
23:18:27:WU00:FS01:0x21:ERROR:Bad platformId size.
23:18:27:WU00:FS01:0x21:Saving result file logfile_01.txt
23:18:27:WU00:FS01:0x21:Saving result file log.txt
23:18:27:WU00:FS01:0x21:[email protected] Core Shutdown: BAD_WORK_UNIT
23:18:28:WARNING:WU00:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
23:18:28:WU00:FS01:Sending unit results: id:00 state:SEND error:FAULTY project:10495 run:12 clone:8 gen:92 core:0x21 unit:0x000000828ca304f555d34df2371a474d
23:18:28:WU00:FS01:Uploading 2.03KiB to 140.163.4.245
23:18:28:WU00:FS01:Connecting to 140.163.4.245:8080
23:18:28:WU00:FS01:Upload complete
23:18:28:WU00:FS01:Server responded WORK_ACK (400)
23:18:28:WU00:FS01:Cleaning up
23:18:28:WU01:FS01:Connecting to 171.67.108.45:80
23:18:28:WU01:FS01:Assigned to work server 140.163.4.242
23:18:28:WU01:FS01:Requesting new work unit for slot 01: READY gpu:0:GF104 [GeForce GTX 460] from 140.163.4.242
23:18:28:WU01:FS01:Connecting to 140.163.4.242:8080
23:18:28:WU01:FS01:Downloading 3.44MiB
23:18:29:WU01:FS01:Download complete
23:18:30:WU01:FS01:Received Unit: id:01 state:DOWNLOAD error:NO_ERROR project:11400 run:17 clone:13 gen:8 core:0x21 unit:0x0000000e8ca304f255de8e3bd0da59b8
23:18:30:WU01:FS01:Starting
23:18:30:WU01:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21 -dir 01 -suffix 01 -version 704 -lifeline 1606 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
23:18:30:WU01:FS01:Started FahCore on PID 5110
23:18:30:WU01:FS01:Core PID:5114
23:18:30:WU01:FS01:FahCore 0x21 started
23:18:30:WU01:FS01:0x21:*********************** Log Started 2016-01-04T23:18:30Z ***********************
23:18:30:WU01:FS01:0x21:Project: 11400 (Run 17, Clone 13, Gen 8)
23:18:30:WU01:FS01:0x21:Unit: 0x0000000e8ca304f255de8e3bd0da59b8
23:18:30:WU01:FS01:0x21:CPU: 0x00000000000000000000000000000000
23:18:30:WU01:FS01:0x21:Machine: 1
23:18:30:WU01:FS01:0x21:Reading tar file core.xml
23:18:30:WU01:FS01:0x21:Reading tar file system.xml
23:18:30:WU01:FS01:0x21:Reading tar file integrator.xml
23:18:30:WU01:FS01:0x21:Reading tar file state.xml
23:18:30:WU01:FS01:0x21:Digital signatures verified
23:18:30:WU01:FS01:0x21:[email protected] GPU Core21 [email protected] Core
23:18:30:WU01:FS01:0x21:Version 0.0.17
23:18:30:WU01:FS01:0x21:ERROR:Bad platformId size.
23:18:30:WU01:FS01:0x21:Saving result file logfile_01.txt
23:18:30:WU01:FS01:0x21:Saving result file log.txt
23:18:30:WU01:FS01:0x21:[email protected] Core Shutdown: BAD_WORK_UNIT
23:18:31:WARNING:WU01:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
23:18:31:WU01:FS01:Sending unit results: id:01 state:SEND error:FAULTY project:11400 run:17 clone:13 gen:8 core:0x21 unit:0x0000000e8ca304f255de8e3bd0da59b8
23:18:31:WU01:FS01:Uploading 2.03KiB to 140.163.4.242
23:18:31:WU01:FS01:Connecting to 140.163.4.242:8080
23:18:31:WU01:FS01:Upload complete
23:18:31:WU01:FS01:Server responded WORK_ACK (400)
23:18:31:WU01:FS01:Cleaning up
23:18:31:WU00:FS01:Connecting to 171.67.108.45:80
23:18:31:WU00:FS01:Assigned to work server 171.64.65.92
23:18:31:WU00:FS01:Requesting new work unit for slot 01: READY gpu:0:GF104 [GeForce GTX 460] from 171.64.65.92
23:18:31:WU00:FS01:Connecting to 171.64.65.92:8080
23:18:32:WU00:FS01:Downloading 2.97MiB
23:18:33:WU00:FS01:Download complete
23:18:33:WU00:FS01:Received Unit: id:00 state:DOWNLOAD error:NO_ERROR project:9161 run:96 clone:0 gen:14 core:0x18 unit:0x00000010ab40415c56746637aa4a020c
23:18:33:WU00:FS01:Starting
23:18:33:WU00:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_18.fah/FahCore_18 -dir 00 -suffix 01 -version 704 -lifeline 1606 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
23:18:33:WU00:FS01:Started FahCore on PID 5118
23:18:33:WU00:FS01:Core PID:5122
23:18:33:WU00:FS01:FahCore 0x18 started
23:18:33:WU00:FS01:0x18:*********************** Log Started 2016-01-04T23:18:33Z ***********************
23:18:33:WU00:FS01:0x18:Project: 9161 (Run 96, Clone 0, Gen 14)
23:18:33:WU00:FS01:0x18:Unit: 0x00000010ab40415c56746637aa4a020c
23:18:33:WU00:FS01:0x18:CPU: 0x00000000000000000000000000000000
23:18:33:WU00:FS01:0x18:Machine: 1
23:18:33:WU00:FS01:0x18:Reading tar file core.xml
23:18:33:WU00:FS01:0x18:Reading tar file system.xml
23:18:33:WU00:FS01:0x18:Reading tar file integrator.xml
23:18:33:WU00:FS01:0x18:Reading tar file state.xml
23:18:33:WU00:FS01:0x18:Digital signatures verified
23:18:33:WU00:FS01:0x18:[email protected] GPU core18
23:18:33:WU00:FS01:0x18:Version 0.0.4
23:18:33:WU00:FS01:0x18:ERROR:exception: Bad platformId size.
23:18:33:WU00:FS01:0x18:Saving result file logfile_01.txt
23:18:33:WU00:FS01:0x18:Saving result file log.txt
23:18:33:WU00:FS01:0x18:[email protected] Core Shutdown: BAD_WORK_UNIT
23:18:34:WARNING:WU00:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
23:18:34:WU00:FS01:Sending unit results: id:00 state:SEND error:FAULTY project:9161 run:96 clone:0 gen:14 core:0x18 unit:0x00000010ab40415c56746637aa4a020c
23:18:34:WU00:FS01:Uploading 1.89KiB to 171.64.65.92
23:18:34:WU00:FS01:Connecting to 171.64.65.92:8080
23:18:34:WU01:FS01:Connecting to 171.67.108.45:80
23:18:34:WU00:FS01:Upload complete
23:18:34:WU00:FS01:Server responded WORK_ACK (400)
23:18:34:WU00:FS01:Cleaning up
23:18:34:WU01:FS01:Assigned to work server 171.64.65.61
23:18:34:WU01:FS01:Requesting new work unit for slot 01: READY gpu:0:GF104 [GeForce GTX 460] from 171.64.65.61
23:18:34:WU01:FS01:Connecting to 171.64.65.61:8080
23:18:35:WU01:FS01:Downloading 2.78MiB
23:18:36:WU01:FS01:Download complete
23:18:36:WU01:FS01:Received Unit: id:01 state:DOWNLOAD error:NO_ERROR project:9145 run:16 clone:1 gen:107 core:0x18 unit:0x000000800a3b1e6155a85041c0a64dc6
23:18:36:WU01:FS01:Starting
23:18:36:WU01:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_18.fah/FahCore_18 -dir 01 -suffix 01 -version 704 -lifeline 1606 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
23:18:36:WU01:FS01:Started FahCore on PID 5125
23:18:36:WU01:FS01:Core PID:5129
23:18:36:WU01:FS01:FahCore 0x18 started
23:18:36:WU01:FS01:0x18:*********************** Log Started 2016-01-04T23:18:36Z ***********************
23:18:36:WU01:FS01:0x18:Project: 9145 (Run 16, Clone 1, Gen 107)
23:18:36:WU01:FS01:0x18:Unit: 0x000000800a3b1e6155a85041c0a64dc6
23:18:36:WU01:FS01:0x18:CPU: 0x00000000000000000000000000000000
23:18:36:WU01:FS01:0x18:Machine: 1
23:18:36:WU01:FS01:0x18:Reading tar file core.xml
23:18:36:WU01:FS01:0x18:Reading tar file system.xml
23:18:36:WU01:FS01:0x18:Reading tar file integrator.xml
23:18:36:WU01:FS01:0x18:Reading tar file state.xml
23:18:36:WU01:FS01:0x18:Digital signatures verified
23:18:36:WU01:FS01:0x18:[email protected] GPU core18
23:18:36:WU01:FS01:0x18:Version 0.0.4
23:18:36:WU01:FS01:0x18:ERROR:exception: Bad platformId size.
23:18:36:WU01:FS01:0x18:Saving result file logfile_01.txt
23:18:36:WU01:FS01:0x18:Saving result file log.txt
23:18:36:WU01:FS01:0x18:[email protected] Core Shutdown: BAD_WORK_UNIT
23:18:37:WARNING:WU01:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
23:18:37:WU01:FS01:Sending unit results: id:01 state:SEND error:FAULTY project:9145 run:16 clone:1 gen:107 core:0x18 unit:0x000000800a3b1e6155a85041c0a64dc6
23:18:37:WU01:FS01:Uploading 1.90KiB to 171.64.65.61
23:18:37:WU01:FS01:Connecting to 171.64.65.61:8080
23:18:37:WU01:FS01:Upload complete
23:18:37:WU01:FS01:Server responded WORK_ACK (400)
23:18:37:WU01:FS01:Cleaning up
23:18:43:WU02:FS00:Starting
23:18:43:WARNING:WU02:FS00:Changed SMP threads from 7 to 6 this can cause some work units to fail
23:18:43:WU02:FS00:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/Core_a4.fah/FahCore_a4 -dir 02 -suffix 01 -version 704 -lifeline 1606 -checkpoint 15 -np 6
23:18:43:WU02:FS00:Started FahCore on PID 5134
23:18:43:WU02:FS00:Core PID:5138
23:18:43:WU02:FS00:FahCore 0xa4 started
23:18:44:WU02:FS00:0xa4:
23:18:44:WU02:FS00:0xa4:*------------------------------*
23:18:44:WU02:FS00:0xa4:[email protected] Gromacs GB Core
23:18:44:WU02:FS00:0xa4:Version 2.27 (Dec. 15, 2010)
23:18:44:WU02:FS00:0xa4:
23:18:44:WU02:FS00:0xa4:Preparing to commence simulation
23:18:44:WU02:FS00:0xa4:- Looking at optimizations...
23:18:44:WU02:FS00:0xa4:- Files status OK
23:18:44:WU02:FS00:0xa4:- Expanded 118288 -> 268292 (decompressed 226.8 percent)
23:18:44:WU02:FS00:0xa4:Called DecompressByteArray: compressed_data_size=118288 data_size=268292, decompressed_data_size=268292 diff=0
23:18:44:WU02:FS00:0xa4:- Digital signature verified
23:18:44:WU02:FS00:0xa4:
23:18:44:WU02:FS00:0xa4:Project: 6391 (Run 29, Clone 26, Gen 321)
23:18:44:WU02:FS00:0xa4:
23:18:44:WU02:FS00:0xa4:Assembly optimizations on if available.
23:18:44:WU02:FS00:0xa4:Entering M.D.
23:18:49:WU02:FS00:0xa4:Using Gromacs checkpoints
23:18:49:WU02:FS00:0xa4:Resuming from checkpoint
23:18:49:WU02:FS00:0xa4:Verified 02/wudata_01.log
23:18:49:WU02:FS00:0xa4:Verified 02/wudata_01.trr
23:18:49:WU02:FS00:0xa4:Verified 02/wudata_01.xtc
23:18:49:WU02:FS00:0xa4:Verified 02/wudata_01.edr
23:18:49:WU02:FS00:0xa4:Completed 430400 out of 5000000 steps  (8%)

Any suggestions? Otherwise I'll can choose from 173, 310, 319 331, 340, 346 and 352 (Available in the Mint repo - there may be other versions that I could install direct from Nvidia.)

Thanks!
 
OP
HankB

HankB

Member
Joined
Jan 27, 2011
Location
Beautiful Sunny Winfield
as for not finding the gpu, you need to go config/expert, back in there you will find where the cpu, the gpu and all that is listed.
you will find that gpu is noted as false, change this to true and it should pick up the card on restart.
I would go into more detail but I don't have a Linux rig in the house right now.
good luck.

No joy. :(

3.46 was not available so I installed 352.63. I went to Configure -> Expert and set GPU to true (where it remains.) When I try to add the GPU slot I get a popup stating there is no GPU available. There is no hint of why no GPU is available in the log.
 

caddi daddi

Godzilla to ant hills
Joined
Jan 10, 2012
do you have one cpu core free per gpu?
with nvidia cards you need one core to operate each gpu.
 

HayesK

Member
Joined
Oct 11, 2008
Sometimes the drivers do not install all the support files correctly. Try purging all the nvidia files , rebooting, then re-install the drivers.
sudo apt-get purge nvidia*
sudo apt-get install nvidia-304

Perhaps there is issue with missing gpus.txt file on the host not recognizing the gpu. Not at home to verify the file location, but think the location and how to download was discussed in prior thread.

304.131 runs fine on my Kepler cards. Need the 300 series to fold. 327 or less will avoid the core_17 slowdown issue on kepler/fermi. Think I had 319 folding in the past. 310 should work.

Have one Maxwell host running with driver 358.16, but it is about 10% slower than 346.96. Ubuntu installed 352 when I applied some updates a few weeks ago and all attempts to re-install 346.96 from the ppa resulted in 352, so I went with 358.16 until I have time to install a copy of 346.96 downloaded from nvidia.
 
OP
HankB

HankB

Member
Joined
Jan 27, 2011
Location
Beautiful Sunny Winfield
have you rebooted the system?

Yes, but apparently not enough. I rebooted again just to be sure and now I can add the GPU slot. It's still not folding. It errors out using both 352 and 340 drivers with:
Code:
02:57:41:WARNING:WU01:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)

<sigh>

At least is is relatively easy to change driver versions these days.

thanks,
hank