• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

GPU not used. strange behaviour in monitoring programs

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.


New Member
Jul 8, 2014
Hello people!

I have a problem with my nVidia 750m and I need your help. I'm pretty sure the inevitable has already happened but inside me there is still a flicker of hope and I just wanted to hear a second opinion.

my laptop> Acer Aspire V5 573G, intel core i5-4200U
nVidia GT 750m 4096 MB, 967 MHz, : 900 MHz, DDR3,
8GB RAM, Windows 7 x64

the dedicated GPU (NV750m) has apparently stopped working. although it is found and listed in device manager and in the nVidia Control Panel, setting it as default in the "global" profile or choosing "run with graphics processor- High Perf. Nvidia" does nothing to actually start the GPU. I get low FPS in games because only the integrated Intel GPUcan be used (and GPU-Z detects its usage at 100%).
the 750M meanwhile is at 0% usage and up to 8% sometimes even 23% (can those be just artifacts?) and exhibits the same strange pattern of individual spikes with the clocks and load indicators switching between their values and "-- %"

here are the screenshots

notice the missing Bandwidth value.... CUDA and DirectCompute shouldn't be missing also , right?


I started a game in the middle of the testing period but patterns don't change as with the integrated Intel GPU below

everything is alright with the integrated intel GPU

it started when I was playing a long session of Mount & Blade and it started lagging slightly at certain places. Now M&B is not a GPU heavy game so i didn't realize that maybe the 750m had just turned off.
Next day all 3d games and graphic rendering programs were at >halved fps.

What I tried so hard and got not so far:

*reinstalling nVidia drivers. (clean install)

*disabling and uninstalling the integrated intel GPU driver and restarting results in windows booting with the basic VGA drivers... 3d games don't start at all

*last known configuration

*system restore to 1 day before it happened

*getting the same reading from MSI afterburner , same spiky pattern , but there the spikes have lower peaks (max usage 4%)

*CCleaner - registry repair

*DxDiag shows only integrated Intel GPU but I think it could be normal .... Is there a way to REINSTALL DX ?

*in BIOS there is no option to choose witch GPU to boot with

*everything is stock and hasn't been OC

the only other thing I can remember but I think is irrelevant is that I installed iTunes to listen to a stupid podcast from the university and it messed my DAEMON TOOLS somehow (I didn't know back then iTunes was the culprit) so it wasn't able to mount a virtual image. I should had fixed this by simply uninstalling iTunes but I followed the solution of some guys in the DT forum to delete those two registry entries:

"UpperFilter" and "lowerFilter" values from HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318} .... it has prob. nothing to do with the GPU problem

I'm at loss here. I think the card is gone. It's still in warranty but having to backup everything and reinstall the whole system would be pain in the a**.

Edit: I do apologize if this isn't the right place to post this. please be so kind to move it's if so.
You've tried everything that I would have. You didn't mention this, but I want to make sure you've tried it: did you check the power profile in Windows? The low power setting does not switch to the nvidia card, if I remember correctly.