• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

graphical issues? *artifacts* with rx 570 gigabyte 4gb

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

squallypo

New Member
Joined
Oct 15, 2018
Hello dear Overclockers, i need someone to really put me at ease about this situation im having, i dont know if my two weeks brand new gpu is the culprit of my issues ive encountered so far within gaming or if its something else, but i do gotta say before this gpu my gtx 750 ti had no issues with final fantasy xv benchmark i cant confirm about having no issues with battlefront 2 though, im gonna keep testing other intensive gpu games to see whats going on but its really an issue for me having to go threw these troubles to figure out if there's something wrong with the hardware or its just engine related with the games. the issues ive so far encountered can be described as *graphical artifacts* but no green boxes, blue , triangles ive not overclocked the card, infact the only thing ive done was to undervolt it but even that i reseted it to default and reinstalled drivers a lot of times. i cant put to words what ive experienced so im gonna leave a link of a video i took so you can see whats going on, i hope you can give it a check:
the same thing happens in the final fantasy xv benchmark but it doesn't happen often like it does in this game. please help me out.

my system: rx 570 gigabyte gaming 4gb asus b85m-e/csm motherboard evga 500watts 80white plus PSU 4x2 ddr3 1600mhz dual channel ram windows 10 pro 1709 build
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
Not sure I saw anything there at all? Can you point out to us where (time) in that video you are seeing glitches?
 
OP
S

squallypo

New Member
Joined
Oct 15, 2018
Not sure I saw anything there at all? Can you point out to us where (time) in that video you are seeing glitches?

i also did a occt test but im not sure if i configured it properly, if you could tell me that would be helpful:
now about the issues idk if you manage to see some kind of flickering with the enviroment it happens at specific moments and its just for a mere second or so, the thing is that those issues happen way often over the multiplayer section of that game, i also tested on the final fantasy xv benchmark which i know its not quite accurate i think considering how the benchmark was awfuly optimized, yet i saw the same thing i got with battlefront 2 but only a few times, gotta mention my gpu is currently on defaults im not touching wattman anymore.

going back to the video check these times: second 37,52, 1:10, 1:22,1:32,till the end of the video.
idk its some kind of graphical enviroment flickering idk how to put it like..
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
I saw it now...

Have you tried other drivers? What troubleshooting have you gone through already so we do not duplicate suggestions?
 
OP
S

squallypo

New Member
Joined
Oct 15, 2018
I saw it now...

Have you tried other drivers? What troubleshooting have you gone through already so we do not duplicate suggestions?

ive tried other drivers and yeah same outcome, idk if this is normal, driver issue, hardware i really dont know anymore.
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
Not sure. If it happens in all games, I would say it is the card. But is it?

When you tried other drivers, did you use a program like DDU to COMPLETELY uninstall drivers?
 
OP
S

squallypo

New Member
Joined
Oct 15, 2018
Not sure. If it happens in all games, I would say it is the card. But is it?

When you tried other drivers, did you use a program like DDU to COMPLETELY uninstall drivers?

yes, ive used DDU to eradicate the drivers and install the new ones, so far the only games ive tested is dead by daylight, star wars battlefront 2 ea, ni no kuni 2, i gotta try something different im downloading deus ex manking divided to stress the gpu out, but either way idk whats up really... idk if you checked my OCCT test but then again im a newbie so idk if i set the configuration right before doing the test, and either way idk if that clears things out withing the hardware aspects of the gpu.
other than that ive test heaven benchmark at high and tess with extreme no crashes thats all i can say.
 

Johan45

Benching Team Leader Super Moderator
Joined
Dec 19, 2012
Did you use the DDU software to remove all the previous Nvidia drivers? there's a selection on the main GUI for AMD/Nvidia
 

trents

Senior Member
Joined
Dec 27, 2008
I didn't watch the whole thing but I only saw a noticeable flicker once toward the beginning of your video clip and I'm not sure I saw any artifacts. I To me that doesn't seem like much of a problem and unless it gets worse I wouldn't worry about it.
 
OP
S

squallypo

New Member
Joined
Oct 15, 2018
I didn't watch the whole thing but I only saw a noticeable flicker once toward the beginning of your video clip and I'm not sure I saw any artifacts. I To me that doesn't seem like much of a problem and unless it gets worse I wouldn't worry about it.

what if it happens in two or 3 games ? yes the flicker is there im wondering if this is a sign of a faulty gpu or something else on the hardware side.