• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Hatches for cooler broke off on L7VTA

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

INFERNO2

Member
Joined
Apr 1, 2003
Location
Europe
Please supply the best way to repair it!

I festened my water block to tight it puled all 3 hatches on lower side of socket!

Than You!
 

Puer Aeternus

Member
Joined
Sep 23, 2001
Location
In your head (Ottawa.Canada)
Good luck, I broke a lug off the socket of my k7s5a w/ a old Tt mini super orb. Luckilly there is just enough lug left to hold a Volcano7 on..still pretty risky but so far so good.
maybe ask this question in the general computer discussion thread...more traffic there.
 

PDL

Member
Joined
Apr 21, 2001
Location
OH-Heartland of the USA
Unfortunately this is one of the boards by ECS that does not have the 4 mounting holes around the SocketA...no help there!
About the only thing I can think of is to replace the top part of the socket. If memory serves me correctly the top snaps over another piece. It would be delicate work and you would need to find some junk boards to get the pieces from.
May be worth a try since you cannot use the thing anyway.
The only other suggestion would be to epoxy the heatsink to the mainboard. :eek: But there you run the risk of the epoxy tearing loose from the mobo surface...and taking solder traces with it.:D