• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Help need 6800(nu)

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Jarlaxe

Disabled
Joined
Apr 15, 2004
Location
Seattle, Washington
I made a post at gaming sections of these forums, but nobody seems to reply. Title:"Dissappointed...Morrowind" Basically, to sum it up Morrowind won't run as well as I think it should. You can reply here or at the games forums. I need help figuring this out. Also which drivers are the best for 6800nu. Do i need DirectX 9.0c? Any hel would be HIGHLY APPRECIATED! Thank you, I'm desparate:)
 

kiyoshilionz

Member
Joined
May 20, 2004
Location
Wheaton, IL
I think Morrowind has always been bad no matter what video card you have. I had a GeForce3 Ti200, my friend upgraded to a Geforce4 Ti4600 and it was only marginally better. And then another one of our friends got a Radeon 9700 and it was only a bit better again. So I don't think this game will ever be too great. I haven't played it in a long time but I just remember this game constantly being slow no matter what system you are on.
 

Kunaak

Member
Joined
Sep 28, 2002
Location
Juneau Alaska
I ran Morrowind for the last few weeks at 1280x1024 with every single driver option maxed out, max draw distance and shadows and every other concievable option in the game maxed out, for the smoothest visuals I ever seen in a single game.

I was in heaven.

that was with my FX51 and X800 pro.
well I sold that FX51, getting ready for a upgrade and went back to my p4

with my P4 and X800 pro...
the game is just laggy.
all the features had to be dumbed down.
the videocard drivers still can be maxed out.
but shadows, draw distance now kill the game.

I think this game has something to do with the cache and overall CPU power, cause my fx51 at 2.5 ghz, absolutly demolished morrowind and asked for more.

but my 3.5 ghz P4 is cringing under morrowind.
even with the same videocard-the X800 pro that just a few days earlier was doing so damn well on it.

I'd say the problem lies in pure CPU power, if I had to really guess.
cause this game CAN run beautifully, and smooth as silk.
but it just won't happen with my P4.
 
OP
Jarlaxe

Jarlaxe

Disabled
Joined
Apr 15, 2004
Location
Seattle, Washington
Hmm. I would assume a gig of Corsair XMS 3200 and a Barton 3200 should be overwhelming for a 2-year-old game. I maxed out everything as well, but in Balmora my frames are from 25-42, indoors its like 200. This is with 4xAA 16xAF, when I set it down to 4xAf there is almost no difference. Anyone else have any numbers for me? I would a assume a Nvidia 6800(nu) would still rip apart a 9800xt in Morrowind right? Also does it matter where the silder is in performance? Like High Performance-Performance-Quality-High Quality?
 

Gregory_WE

Member
Joined
Jun 19, 2002
Morrowind runs great on my system in the sig (P4 2.26 with Ti4600).

Maybe you're having software/driver issues?
 
OP
Jarlaxe

Jarlaxe

Disabled
Joined
Apr 15, 2004
Location
Seattle, Washington
WTF on a ti 4600???? What kind of frames your getting, resolution, etc. I'm at 1280x1024 full shadows, full AI, sound, full LOD 4xAA 16X AF and hovering in Balmora at 25-42, inside over 200, nature goes around 45. Gregory please explain...!!