• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Help! Sudden micro stutters / frames skip.

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.


Jan 15, 2016
it began when i was playing ,and i noticed that i have accidently set my gpu memory clock to +221 (Mem was running at 3222Mhz )in msi afterburner and i was getting stutters (still at 60 fps )..so i put it back to "default" and its still there... in ALL games . i tried to reeinstall nvidia drivers and it didnt worked ,tried to restore to a save point , but it still there anyway ..note that the gpu temp didnt go upper than 70 C with 50% fans ..i dont know what to do .. i have a gtx 760sc 2gb gddr5
One place to look is to see what other programs you have running. You may have an issue where multiple programs are fighting for your system resources.

Another idea would be to remove the drivers by using a program called DDU (Display Driver Uninstaller) to completely remove the drivers then reinstall a slightly older set of drivers that you feel comfortable with.

Also, make sure that you didn't get too aggressive with your graphics settings in your game(s).
My Specs !sorry , just came back from school . I was playing dark souls 2 sotfs , everything was perfectly fine. and i have a i5-4670k 3.4ghz cooled with a evo 212 , a asrock b85 pro4 as mother board , 8gb ram kingston hyperX Blu , a Cooler Master i700 - 700W Power Supply 80 plus , a kingston 120 gb SSD along with a 1to sandisk hdd
and a gtx 760 sc From EVGA btw srry for my crappy english :p
the stutters i have gotten have always been caused by having my graphics settings a bit to high for my res or my game having to load something from a slow hdd.
are you installed on an hdd or ssd?

have you tried setting your graphics settings back a notch.
im playing at 1920x1080

- - - Updated - - -

changing graphics setting didnt do
anything :/..
install GPU-Z if you already don't have it and confirm that the PCI-E slot is running at the right speed.
Try using a little bit older driver, sometimes the newest drivers don't play well with older hardware.