• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Help with games not opening HP Reverb G2 VR Headset.

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

dfonda

Senior Golfer
Joined
Feb 25, 2004
So I have been banging my head against the wall for 2 days looking for a solution to why a few games will not open the in this VR headset (HP Reverb G2) They try to open then quit. The issue seems to be in the games in Steam as opposed to WMR software. Now admittedly I am a noob at VR and software isn't really my forte'.

The Hardware itself is high end #0 in sig. Alder Lake, RTX 3080. I have watched a lot of youtube on how to properly open games from a german guy I think he is...I would think that the software needed is opening itself but I do make sure it is open. WMR first, Steam, SteamVR, WMR for Steam...That is a lot of layers for one game...(I wished I had gotten the index) (No FB Oculus was out)

I started in sit environment so my wife (Wheelchair) could use it. Switched to a 5x7 in case that was an issue.

1) Things that work....Google Earth, Theblu, and a couple of other travel type apps ,free from the Windows Store. Also the VR Rooms, all work and the VR objects you can place in the rooms work.

2)Things that have not worked. First was Everest VR. It wasn't listed as working on the G2, but I figured it would. Tried to open but left me in the open expanse. I returned it for credit to Steam. Picked 2 more a set really Episode 1 and 2 of "The Gallery" listed as working in this headset. Same thing gets me to the EULA (About not crashing into things) but after accepting in 5 seconds or so leaves me in the expanse.

3) Things I tried this morning verified integrity of SteamVR (Properties/Files) and both games. No help.
The only taxing program I pause is Folding at Home. I would try Task manager shut down, but there are so many random apps to close, I just would choose not to play the game. I only have Linux on my other 2 PC's and using them is not really an option as they do science 24/7 ([email protected]).
Also reinstalling Windows isn't happening as this install is fairly new and doesn't have much installed. Used for fah, MKV, and web browsing and of course gaming primarily through Steam.

I hope there is an easy solution.

Thanks for any help.(y)
 
Last edited:
OP
dfonda

dfonda

Senior Golfer
Joined
Feb 25, 2004
Ok I will be able to return this to HP. I will be trying the Index next.

I am curious if someone has this G2 headset working well...and if they had any issues to deal with ?
 

JLK03F150

What have I done! Member
Joined
May 17, 2005
Location
Georgia
I have an HP headset that is two (or more?) versions older than the G2. It took a lot of fiddling to get it working at first. The only game I'm currently using it in is Live for Speed - a racing sim from 2004-05, but it works great there. I would like to try it in several other games, just haven't had the time to experiment with it.
 
OP
dfonda

dfonda

Senior Golfer
Joined
Feb 25, 2004
Questions to ask, research and exploration:
1. User permissions for OS and Applications
2. HDCP fully compliant
#0 in sig , Yes and Yes it was built by me so user name (Me) has full admin. It works it just doesn't open 3 of the games it should.

Good thread for anyone else , but I dropped this headset at Fedex RA for credit this morning, not going to waste another minute on it...deciding if I want an index or not. I can get rid of the layers of WMR software then.

It is not a new headset and neither are the games not running. I thought by now VR would be plug and play...but it is not.

Used this to see what I missed, but I had already done all this. Headset was set up correctly from the get go.

 
Last edited: