• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

help with kernel compile!

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

funnyperson1

Senior Member
Joined
Jun 16, 2001
ok now, i tried following the guide for installing a linux kernel here:
http://www.linux.org/docs/ldp/howto/Kernel-HOWTO.html

when i say make xconfig it goes out giving me several errors:

make[1]: gcc: Command not found
make[1]: *** [tkparse.o] Error 127
make[1]: Leaving directory `/usr/src/linux-2.4.19/scripts'
make: *** [xconfig] Error 2

then i try make menuconfig and it gives me an error saying i dont have ncurses and so i dled ncurses and when i typed ./configure it said this:

checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable cc found in $PATH

then i did make config and when through the LOOOOOONG process of configuring there and that seemed to work

but when i typed make dep, it gave me another error:
/bin/sh: line 1: gcc: command not found
gcc -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -o scripts/mkdep scripts/mkdep.c
make: gcc: Command not found
make: *** [scripts/mkdep] Error 127

so please help me, do i need to install c++ for this to work? teach me :)
 
OP
funnyperson1

funnyperson1

Senior Member
Joined
Jun 16, 2001
if i do need to install gcc tell me how to do it, redhats package upgarding utility is missing something that i had update using RHN and now wont let me install without the old version :(
 
OP
funnyperson1

funnyperson1

Senior Member
Joined
Jun 16, 2001
never, mind i got gcc installed and now make dep works...after i install this kernel ima try to do a make menu config after installing ncurses because, make xconfig still gives me errors :(
 
OP
funnyperson1

funnyperson1

Senior Member
Joined
Jun 16, 2001
i just compiled my first kernel :)....but internet and other things dont work in it :(....in config i dont see a place to enable intel lan cards, how do i configure my ethernet card, its an Intel InBusiness 10/100 card
 

Tiger

Member
Joined
Apr 6, 2001
Location
UK
Under root -> modconf
This should produce a menu with many options with the 2.4.xx kernel.
As a fellow newbie to Linux may I suggest you investigate Debian version. Once you get the hang of dselect and apt-get it is a fantastic platform and very powerful. The reason I suggest this is because of the hassles you are experiencing. If you want an app or new kernel with with deselect Debian automatically works out the dependencies, downloads them and then instals them for you. There are many features for upgrading and updating system files and security.
 
OP
funnyperson1

funnyperson1

Senior Member
Joined
Jun 16, 2001
thanks, but actually compiliing the kernel was one of the tasks that i have to do for my network admin class (we define our own goals), so i could learn better how linux works....so i think ill have to work out the hassles as part of a learning process, so i can maintain my A from last qurater:D ...i will try modconf tonight
 

moorcito

Member
Joined
Sep 19, 2002
Location
Chicago, IL
You might have to first figure out what driver runs your NIC, just because it might not say "intel" doesn't mean that it doesn't run.

Are you doing this on a laptop? 'Cause if you are, then you have to add PCMCIA support into the kernel, and then have the cardmgr daemon running in order to get PCMCIA cards working right.
 
OP
funnyperson1

funnyperson1

Senior Member
Joined
Jun 16, 2001
i still have the orginal redhat install, how would i see what driver it is running? this is on my desktop no pcmcia...and this isnt just an intel chipset card, this is made by intel :)....
 
OP
funnyperson1

funnyperson1

Senior Member
Joined
Jun 16, 2001
ok, when compiling again i saw an option for the etherexpress pro cards, but still when loading it gives me "cant detect IP error" i really am a n00b and then i tried tried enabling kernel autodetect IP using DHCP which is what ive always selected during installs....but that didnt work either...no choice for e100 drivers