• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Hmm.... 2 new echo's stopped, others working.

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.


Senior Golfer
Feb 25, 2004
N of splat W of Torin
As of this morning our 2 newest Echo's stopped working and can't connect on reset (Through all known troubleshooting). Old Echo (First gen) still working and at least 3 Dot's working.

I'll continue trying. Not finding anything reported for today...The servers are working.

My wife(Disabled) needs these so I shuffled the working ones where she needs them...Thankfully I have spares.
Solved...reinstalled app on phone rebooted phone...finally app worked to do a factory reset. Their last update (yesterday) bonked the app.

One fixed one to go. (y)

Finicky but the 2nd reset...
Last edited:
Ha! Ha! when I played the video in the above post my own echo dot in another room "echoed" what Alexa was saying in the video.