• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

How to disable automount with Redhat 8?

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Black_Paladin

Member
Joined
Sep 5, 2002
Location
Boise, ID
For the life of me, I can't seem to be able to disable automount in Redhat 8!
I comment the line referring to the CD in my /etc/fstab file but Redhat just inserts another uncommented line below my commented line automatically!!! :mad: :mad: :mad:

Any ideas?
 

moorcito

Member
Joined
Sep 19, 2002
Location
Chicago, IL
Keep the line referring to the cd in your fstab, but you'll need to make it look something like this:
/dev/hdc /cdrom iso9660 noauto,user,ro 0 0

Really, the only important part to add is the noauto (that disables automount). Read 'man fstab' for more info.
 
OP
Black_Paladin

Black_Paladin

Member
Joined
Sep 5, 2002
Location
Boise, ID
Hmmm, mine does say noauto though and yet it still wants to automount when I put a CD in. I think noauto by itself is not enough.

Funny thing is that everytime I put a CD in the drive, Linux will freeze completely and then I'll have to shut down the computer from the power button. No matter what CD I put in, the drive light will flash once and then again to mount this time and BOOM, Linux dead.

I DID get it to stop automounting by using a line I copied and pasted from a website but now I can't remember where I got it from. When the automounting was disabled, I was able to read my CD's fine by manually mounting them. Worked like a charm.

Both Redhat 8's and Mandrake 9's automount is a plague!! Makes Linux look like Windows. :mad: :mad: At least on Mandrake 9, automount doesn't crash Linux when you put a CD in.
 

moorcito

Member
Joined
Sep 19, 2002
Location
Chicago, IL
If you are using gnome, another thing to look at would be the automount settings in the control panel. I can't remember exactly what it is under, since I don't use gnome anymore, but there is an option to disable automount. I'm sure disableling it will fix the problems that you are having. I don't use kde either, but I'm sure that it has a feature in there also.

Your last post reminded me of something, that I didn't think of. The noauto in the /etc/fstab refers to automounting a cd only on boot. That's why when you comment it out, the gnome/kde automounter adds it back in.
 
Last edited:
OP
Black_Paladin

Black_Paladin

Member
Joined
Sep 5, 2002
Location
Boise, ID
Your last post reminded me of something, that I didn't think of. The noauto in the /etc/fstab refers to automounting a cd only on boot. That's why when you comment it out, the gnome/kde automounter adds it back in.

Aaah, OK, that makes sense. Thanks for the info. This explains why I can't boot into linux with a CD in the drive now too. I get the KDE or GNOME initialization screen and in the middle of it the cd will automount and then the system will freeze.

So, since Redhat just puts that /dev/cdrom /mnt/cdrom line back when I comment it out, is there a way to somehow modify it to make it unusable? That way, since the line is still there, maybe Redhat will think that it will work and won't bother putting another line.

I'll actually try filling it in with junk to see if it disables automount?



`killall -9 amd` maybe?

I suppose killing the process is one way of doing it but is there a way to make the disabling of automounting more permanent? I'll try the killall -9 amd and if works, can I put that in a script file or something to execute at bootup? Will putting this line in bash.profile work?
 
OP
Black_Paladin

Black_Paladin

Member
Joined
Sep 5, 2002
Location
Boise, ID
killall -9 amd` maybe?

I tried it and it didn't work. Is amd the automount daemon? Couldn't find it in my list of processes either. :( Any other ideas? Having linux totally go fubar when putting a CD in the drive is really annoying peeps. Help.
 

PolyPill

Senior Member
Joined
May 20, 2001
Location
Germany
If you're using RH8 then there's a service control utility. Just uncheck amd and it wont start up next time. You can also stop it by doing /etc/init.d/amd stop
 
OP
Black_Paladin

Black_Paladin

Member
Joined
Sep 5, 2002
Location
Boise, ID
If you're using RH8 then there's a service control utility. Just uncheck amd and it wont start up next time. You can also stop it by doing /etc/init.d/amd stop

First of all, I have to say that I do not know what amd is. I am guessing that it is short for "AutoMount Daemon" and asked that but got no reply. IF amd is the automount daemon and if it is a service I can't find it.

There is indeed a service control utilty and I checked all the services there thoroughly but there is nothing that even remotely corresponds to an automount daemon.

As a further note, I am now beginning that the problem might not be with automounting. I got a MP 7083A Cd writer and it's the only CD drive on my system. With it, using KDE or Gnome or whatever, as soon as try to mount a CD, Linux will freeze totally instantly.

So much for a stable OS which will not even let me use my CD drive out of the box. (to me an OS that just crashes when you put a CD in your dirve is a joke). I used to have a lot of respect for Linux and I still do because it's open source but the more they make it look like windows, the worse it gets. My Windows XP is 100 times more stable. Well, at least I can get my cd drive to work there...

Sorry for dissing Linux, I understand nothing;s easy when you are using Linux but something as simple as being able to browse a Linux CD, I think that should be expected to work out of the box without weeks of configuring and troubleshooting. It might be fun modifying Linux but I don't want to be building my own OS just to work with my hardware. I would call that "Palux" then.
 

moorcito

Member
Joined
Sep 19, 2002
Location
Chicago, IL
Like I said before go to the gnome control panel, it's the thing that looks like a tool box. Some where under the multimedia section, there should be a tab that corresponds to CDs. There will be an option that says something like 'automount cd on insertion', and all you have to do is uncheck the box to stop automounting. Try starting your computer without the cd, so that you can actually get to gnome, uncheck the box, and put a cd in to see what happends.

I've used RH 5.* to RH 7.2, and I know that option is in there. I'm not sure about RH 8.0 because I haven't used it that much.

And don't just go with RH, if it doesn't work for you like you want, you should try something another distro.
 

firebird79

Member
Joined
Mar 24, 2002
i don't know how much change from RH7.3 to RH8.0, but i think u can found it in Program -> Settings -> Peripherals -> cd properties if u using gnome. you can see the setting and disable the automount from there. good luck
 

PolyPill

Senior Member
Joined
May 20, 2001
Location
Germany
If you think it's a problem with the cdrom drive compatability then disabling auto mounting isn't going to fix it. I don't think it'd really fair to blame linux for the manufacturer not following standards which have been used for the last decade.

The cdrom drive is a pretty standard thing and I've never ran across one that isn't compatable, but I don't have any new hardware. My burner is a scsi 4x.