• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

How to overclock G.SKILL Ripjaws 4 Series DDR4 2400

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Meatball0311

Registered
Joined
Mar 9, 2012
I want to overclock my memory and do not have the faintest clue on where to start.

Motherboard: ASUS ROG STRIX X99 GAMING LGA 2011-v3 Intel X99

CPU: Intel Core i7-5820K Haswell-E 6-Core @4.5GHz LGA 2011-v3

Memory: G.SKILL Ripjaws 4 Series 32GB (4 x 8GB) 288-Pin DDR4 SDRAM DDR4 2400 (PC4 19200) Desktop Memory Model

Right now my memory is being read in the BIOS at a speed of 2133 and I want it to run at 2400.

1) My CPU says that it can run a max of 2133.... does that mean I can only run my memory at 2133 and that is why it is being read that way?
 

NeonCancerCandy

Member
Joined
Feb 26, 2013
Location
Southwest Michigan
activate the XMP profile. I dont know asus bios so i can't tell you exactly how to do that, but it should be in the ram settings. probably set to auto currently, just change it to XMP
 

ATMINSIDE

Sim Racing Aficionado Co-Owner
Joined
Jun 28, 2012
The CPU spec of 2133MHz RAM is simply what into Intel officially supports for DDR4.
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
AKA. JEDEC specification.

Just enable XMP and you will be at the stick's rated speeds.

Are you looking to overclock past the stock memory speeds?
 
OP
Meatball0311

Meatball0311

Registered
Joined
Mar 9, 2012
No. I want it to run at the stock speed of 2400MHz, not 2133MHz.

If I enable XMP will it mess with my CPU overclock?
 
OP
Meatball0311

Meatball0311

Registered
Joined
Mar 9, 2012
I switched it to XMP and when I boot up windows gets stuck on the load screen.
 

wingman99

Member
Joined
Dec 10, 2003
Was there only one XMP mode? You might have one bad memory stick, check the memory sicks individually with XMP mode to see if they pass. XMP will only change the memory clock and settings.
 
Last edited:
OP
Meatball0311

Meatball0311

Registered
Joined
Mar 9, 2012
Yes the memory sticks are in the correct order. BUT I have not updated the BIOS!!! Crazy me.... hopefully that will work.