• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

SOLVED HP Pavilion Gaming laptop - TPM issues, cannot install W11

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
As the title says, I'm having trouble with getting the system to recognize TPM and therefore install W11. It's enabled and available in the bios, but the health check says it isn't recognized... I tried to reset the key, enabled/disabled, etc. and a fully updated W10 still says the device is not compatible.

It's 2-3 year old laptop with a Ryzen5 3550H with Vega 8 graphics. According to some MS docs, all hardware is compatible.

Any thoughts???

EDIT: The exact model - 15-ec0013dx

EDiT2: I found this... https://h30434.www3.hp.com/t5/Noteb...-found-in-Device-Security/m-p/8202744#M620403

Seems like the OS doesn't recognize the fTPM thing.... Grrrrrrrrrrrrrrrrrrrrrrrrrr

EDIT3: Found this and testing...... https://www.reddit.com/r/ASRock/comments/q7suuo




EDIT4: That last part worked. I updated the BIOS to the latest version, booted into Windows, re-ran the check and W11 compatible!

... that said, it won't pull it automatically so I still have to manually install on this device... WTH?
 
Last edited:
OP
EarthDog

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
I think because I'm so lazy and this laptop doesn't get used much, I'm done searching for it/making effort. In a couple of months when I use it again, maybe W11 will be in the updates, lol!

...after just coming back from Disney (first time!) that's meme is HILARIOUS!!! And now I can't get that whistling song from the old timey MMouse out of my head... thanks..... :rofl: