• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

I can't get to my other drives.

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

ElGriton

Member
Joined
Dec 30, 2000
Location
I thought it was America
I have tried everything I can think of to mount my other drives and partitions in slackware 9.1 and nothing works.

This is my fstab:
/dev/hdf6 / reiserfs defaults 1 1
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

This is my mtab:
/dev/hdf6 / reiserfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
proc /proc proc rw 0 0
usbfs /proc/bus/usb usbfs rw 0 0


And a copy of the output from dmesg.
Could someone please help me? the partitions are NTFS so they need to be ro. I have two drives an 80GB WD and an 200GB WD both on a Promise controller card.
 

Attachments

  • dmesg.txt
    11.6 KB · Views: 69

Christoph

JAPH Senior
Joined
Oct 8, 2001
Location
Redmond, WA
Do you have ntfs support in your kernel and do you know which devices you want to mount? What happens when you try to mount them?
 
OP
ElGriton

ElGriton

Member
Joined
Dec 30, 2000
Location
I thought it was America
OK. I hope this is right. It looks like there is an ntsf module "/ntfs.o.gz" but it seems that insmod fails during boot. The drives I'm trying to mount are hdf1,hdf2,hdf3,&hdf4.
 
OP
ElGriton

ElGriton

Member
Joined
Dec 30, 2000
Location
I thought it was America
I get this
Bash-2.05b$ tar xzf ntfs.o.gz
tar: This does not look like a tar archive
tar: Skipping to next header
tar: Error exit delayed from previous errors
 
OP
ElGriton

ElGriton

Member
Joined
Dec 30, 2000
Location
I thought it was America
OK, ntfs is NOT supported by my kernel. For some reason the module is not loading. Can someone tell me why not? Is there a way to edit or replace this module?
 

SickBoy

Inactive Moderator
Joined
Jan 13, 2001
Location
Minneapolis, MN
I'd think the easiest way to go would be to recompile the kernel using your old .config file and add NTFS read support statically..... it doesn't take more than a half an hour to recompile and install a kernel on most machines.
 
OP
ElGriton

ElGriton

Member
Joined
Dec 30, 2000
Location
I thought it was America
SickBoy said:
I'd think the easiest way to go would be to recompile the kernel using your old .config file and add NTFS read support statically..... it doesn't take more than a half an hour to recompile and install a kernel on most machines.

I just knew someone was going to say that :(. I'm afraid that may be far beyond my capabilities. Unless you can point me to a step by step how to, I'm stuck.
 

fiji

Member
Joined
Jul 14, 2002
Location
berlin
ElGriton said:


I just knew someone was going to say that :(. I'm afraid that may be far beyond my capabilities. Unless you can point me to a step by step how to, I'm stuck.

im guessing your kernel sources are in /usr/src/linux


and that yoru using a 2.4 series kernel


if so


cd /usr/src/linux
make menuconfig
(now go down to fielsystems, and hit M on NTFS)
(now arrow key over and hit exit twice, it will prompt you to save the config save it, and while in /usr/src/linux type)
make dep && make modules modules_install


that will install the ntfs module aswell as any other modules in your kernel config
 

fiji

Member
Joined
Jul 14, 2002
Location
berlin
oh and when you try to mount your ntfs partitition do


mount -t ntfs /dev/hdxy /mnt/weeee
 
OP
ElGriton

ElGriton

Member
Joined
Dec 30, 2000
Location
I thought it was America
fiji said:
oh and when you try to mount your ntfs partitition do


mount -t ntfs /dev/hdxy /mnt/weeee

OK, mount -t ntfs /dev/hdb2 /mnt/drive worked. Whats does the -t do?
After recompiling I no longer have sound. Is there a way to reverse that?

edit: OK, never mind about the -t i found that out. How about my sound though?
 
OP
ElGriton

ElGriton

Member
Joined
Dec 30, 2000
Location
I thought it was America
OK, sound is back. I still can't get ntfs support without doing "mount -t ntfs /dev/hdb2 /mnt/drive" and I still only have access as root. I can live with it like this as I don't really need to go there very often It's just that I can't is whats bothering me.
 

Christoph

JAPH Senior
Joined
Oct 8, 2001
Location
Redmond, WA
ElGriton said:
OK, sound is back. I still can't get ntfs support without doing "mount -t ntfs /dev/hdb2 /mnt/drive" and I still only have access as root. I can live with it like this as I don't really need to go there very often It's just that I can't is whats bothering me.

If you want to be able to mount it as any old user, add user to the mount options (the fourth field) in /etc/fstab.
 

fiji

Member
Joined
Jul 14, 2002
Location
berlin
to mount with a regular user as owner , and not have it in fstab do something like


mount -t ntfs /dev/hdxy /mnt/blah -o uid=user