• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

i think my psu died.. how do i find out 4 sure ?

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Hc000

Member
Joined
Nov 11, 2002
i got home today... tried to turn on the computer... nothing... pressed the power button 15 times.. still nothing then i waited a min then tried again and it worked ! but the screen says no signal and my power supply rumbles every 5 second or so.... this computer is 1 year old and it was preassembled.. how do i know if the psu is the problem? (the cpu fan is running fine)
 

repo man11

Member
Joined
Dec 28, 2001
It sure sounds like a dead PSU.
I really can't think of a way other than swapping in another.
When you say it "rumbles", I guess it is a fan that is making the noise?
 
OP
H

Hc000

Member
Joined
Nov 11, 2002
i hear a sound ever 5 second coming from the power supply, and when i put my hand on it it shakes every 5 second... its a tbird 1400 with 1hdd,1dvd,gf2 pro how many watts does it need ?
 

repo man11

Member
Joined
Dec 28, 2001
Strange. I'd say the usual minimum, 300 watts. If I were you though, I'd go with at least a 350, to give yourself some room for growth in the future.
 

mbentley

Gloriously Lead, Overclockix Chief Architect
Joined
Sep 26, 2002
Location
Indianapolis, IN
umm... if you wanna make sure that it is dead, toss it off the top of a building :D hehe. in all seriousness, i believe it's dead from what you have said. try unplugging it for about 2 minutes or so and then plug it back in then try it again... sometimes when i have a power failure, i have to do that to mine... just try it since you have nothing to lose.
 

The_Mowman

Registered
Joined
Oct 10, 2002
Location
MD
Maybe try unplugging some of your extra components to see if it will fire up with a lot lower load on it. Just an idea...
 

Namagomi

Disabled
Joined
Mar 20, 2001
Location
Dallas, Texas and Tulsa, Oklahoma
repo man11 said:
It sure sounds like a dead PSU.
I really can't think of a way other than swapping in another.
When you say it "rumbles", I guess it is a fan that is making the noise?

uh. he said his PSU fan is running fine. sounds like the PSU is doing fine.

anyways, maybe something else fried. take it to the place you bought it and tell them to check it out.
 

spazzkid

Member
Joined
Sep 28, 2001
Location
Philippines
u kud measure 5 volts and 12volts thru a volt meter, on the molex connector measure red, black. for 12 volts, yellow black.

u kud also take out the psu, and put a jumper on the mobo connector, on the green and black wire which are close to each other. see if it runs fine.

goodluck :D