• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

i5 3570k showing incorrect cpu turbo speed in BIOS

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Mikkee

New Member
Joined
Apr 11, 2016
Hey

So as the title states, im having trouble with my cpu turbo speed. I recently got into overclocking and got to 4.2ghz with stock voltages and it seemed fairly stable. However after opening my case and setting up some fans i booted into bios again and decided to step it up to 4.3ghz. I checked cpu-z and it still showed 4.2ghz. I already tried clearing the cmos and it didn't work. Also realtemp shows 4.2ghz, so i doubt it's a software issue.

Any help please? :/
 

OptyTrooper

Member
Joined
Feb 13, 2010
Location
Missouri
Hey

So as the title states, im having trouble with my cpu turbo speed. I recently got into overclocking and got to 4.2ghz with stock voltages and it seemed fairly stable. However after opening my case and setting up some fans i booted into bios again and decided to step it up to 4.3ghz. I checked cpu-z and it still showed 4.2ghz. I already tried clearing the cmos and it didn't work. Also realtemp shows 4.2ghz, so i doubt it's a software issue.

Any help please? :/

If you cleared the BIOS how is it showing 4.2? It should read 3.4GHz.
 
OP
M

Mikkee

New Member
Joined
Apr 11, 2016
Hey

After i reset cmos it did show the turbo speed of 3.8ghz. I set it to 4.3ghz and booted into windows, but cpu-z still showed 4.2ghz. And just to clarify The oc settings do save in the bios, but im not sure if they are really taking effect. So confused here.
 
OP
M

Mikkee

New Member
Joined
Apr 11, 2016
Damn this place is awesome

Thanks, i disabled turbo boost and re-enabled it and it showed the correct clock speed again. Thanks alot :D