• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Is my NIC working.?

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

ashwin_natesan

Registered
Joined
Oct 16, 2012
Guys,

I own a HP Notebook-15-ac024tx
(http://support.hp.com/us-en/drivers...771404/model/8326082?ssfFlag=true&sku=M9U98PA)
I have connected to internet through ethernet cable and have been using this way for last 8 months.

For the past 2 days, I am having this dreaded "your ethernet doesnt have a valid IP configuration" problem.

1) The first time it occured i did a command prompt release,renew of my IP and a reboot.
It seemed to be working fine for ~5 hours. But got a limited connectivity after this.

2) Then I unchecked my Internet protocol version 6 as instructed through google.
But nothing worked. And out of nowhere, after 2 hours it started working.

3) Meanwhile, I thought only the ethernet part of my NIC was not working and hence tried connecting to a friend's wifi hotpsot.
I could access the internet but it also got into limited connectivity after a while.

4) Right now I am in university, and I am accessing internet thru Wifi and it is working fine for the past 2 hours.

So my question is

Is my ipconfig problem due to NIC card acting weird.?
Is my service provider the culprit.?

What's your take on this.?
 

don256us

Uber Folding Senior
Joined
Jul 17, 2003
The problem could be driver related.
1) Make sure you have the correct driver already downloaded either to the laptop or to a USB drive, etc.
2) Remove everything dealing with your NIC. (Note: Your Ethernet and WiFi will be two separate devices.) NIC = Ethernet. Go into your devices and tell your machine to uninstall the NIC. If asked, removed all drivers.
3) Reboot. It may reinstall while booting up. If it works, you can either leave it alone or update the drivers. If it does not work, install the drivers you downloaded earlier.

You also may just have a bad network cable. Try a different cable. (This ignores the WiFi issue as it may be a red herring.)

You may have a virus. Get a rootkit scanner like Malwarebytes rootkit 1.x beta, Get an anti-malware and spyware like Malwarebytes and Spybot. Give CCleaner a go too. Also make sure you have a good anti-virus like AVG.

In the CMD prompt, do an ipconfig /flushdns and see of that helps.
 
OP
A

ashwin_natesan

Registered
Joined
Oct 16, 2012
The problem could be driver related.

You also may just have a bad network cable. Try a different cable. (This ignores the WiFi issue as it may be a red herring.)

You may have a virus. Get a rootkit scanner like Malwarebytes rootkit 1.x beta, Get an anti-malware and spyware like Malwarebytes and Spybot. Give CCleaner a go too. Also make sure you have a good anti-virus like AVG.

In the CMD prompt, do an ipconfig /flushdns and see of that helps.

I have done the following:
1) installed malwarebytes and it told no cleanup necessary.
2) Tried connecting with a different cable and still the problem exists.
3) did a dns flush.

Before writing this post, I did update my drivers automatically thru Windows and also thru manual download...Even then the problem continued but I am willing to try once more..

Now by "remove everything dealing with your NIC"..what you mean is i uninstall ethernet related driver shown in device management..right.?
 
OP
A

ashwin_natesan

Registered
Joined
Oct 16, 2012
Do you have a router you can reboot?

No..I dont have an router..! the ethernet cable connects directly from my laptop to a wall mounted Plate(one port is called DATA and the other is called COM)..

I am connecting it to DATA port to access internet.
 
OP
A

ashwin_natesan

Registered
Joined
Oct 16, 2012
Guys..!! the problem solved itself.

I sent a mail to my internet provider. Apparently, there was some modification work going on with the cables.

So when I connected my laptop after 2 days, it didnt show as limited connectivity.

I did wait another 2 days to make sure it stayed that way..!!

Thanks for helping in eliminating the obvious guys.!