• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Issue with USB DAC after migrating to an x570 motherboard.

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

PanteraGSTK

Member
Joined
Jul 16, 2001
Hay all, I've got a USB DAC amp combo that until I got my x570 system worked just fine. No matter what I do I get a BSOD from the usbaudio.sys driver buillt into windows 10. This is somehow on multiple PCs now so I'm thinking I've got a defective DAC.

Having said that, I've looked everywhere for an alternate USB driver just to see if that might potentially help, but I'm not having a lot of luck. I found the ASIO4all and can't get it to work because the USB audio device won't start. That's the best I get.

Any ideas or should I just grab a new DAC and be done? Current DAC is a Kanto yaro 2 if that matters.
 

NiHaoMike

dBa Member
Joined
Mar 1, 2013
See if it works on a Linux PC? (Real Linux like Ubuntu, not WSL.) You can use a live distro for that.
 

trents

Senior Member
Joined
Dec 27, 2008
See if it works on a Linux PC? (Real Linux like Ubuntu, not WSL.) You can use a live distro for that.

This. The Linux live distros run from the optical disk and don't require installation on your hard drive. IF the DAC works in Linux then there is indeed an issue with the Windows driver.
 
OP
PanteraGSTK

PanteraGSTK

Member
Joined
Jul 16, 2001
What sucks is that the Windows driver is built in starting in Win 10. I can't find a replacement driver.

I updated my BIOS again so maybe that made a difference.

As for Linux, I've got Zorin dual booted and the DAC works, but it has three devices instead of just the USB DAC. It shows an analog device too and seems to have a lot of static.

I'll try Linux and Windows again after the BIOS update to see if that helped.

EDIT:

I tried it again in Linux and no go this time. It wasn't recognized at all. Windows recognized the device this time without a BSOD, but wouldn't enable it. Unplugging from USB3 port to USB2 didn't help.

Pretty sure it's dead. I ordered a new DAC and an amp so this one can go in the spare pile.

Thanks for the help. Hopefully I won't have the same issue after the new stuff gets here.