• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

SOLVED Keyboard not showing up in Logitech G Hub (SOLVED)

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Oldschool_OC

Registered
Joined
Jan 12, 2015
Was having this problem:

Logitech G Hub "Connect your Logitech gear" when the keyboard was changed to a different port. Switch the keyboard to any other USB port and it shows up just fine.

To be clear the keyboard was working in that port, but Logitech G Hub would not recognize it there.

The printer I use would also not work in the that port, causing me to have to remove the keyboard in order to print.

Checked the driver, and the keyboard would install as "ROG Virtual HID" in that one port.

Some internet search revealed the term "keybot ii" but not in connection with my problem.

Searched "keybot" in the motherboard manual and found out that, that port is connected to a special "keybot" chip, and if the button on the motherboard is pressed, keybot functionality takes over that port. Opened the case and saw that the "keybot" LED was lit up. Pressed the "keybot" button and the LED turned off. Booted the machine back up, re-inserted the keyboard into that port and voilla! Logoitech G Hub now see's the keyboard, even in the port it used to not show up in.

The motherboard is a Maximus VII Hero for reference.

Mostly posting this for anyone else who might run into similar problems.

Cheers!
 

WhitehawkEQ

Premium Member
Joined
Dec 6, 2010
I had an issue with 1 of my PC's not seeing the G110 Logitech KB after post, had to plug in a PS2 KB to install OS then the G110 would work in windows, the fix after years of digging came down to updating the BIOS :)
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
Thanks for posting!

Just an FYI, you should be able to add the SOLVED prefix to your thread. If you look edit the post (may need to be in advanced) there should be a prefix dropdown. :)