• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

LAN/Ethernet Port not working at all on ASUS z170 Pro Gaming MOBO?

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Kooru_

New Member
Joined
Jan 9, 2017
Hey!
First of all I'm not sure If this is the right forum for a post like this. But I'm getting desperate.

I "upgraded" my PC yesterday.

Old parts:
Asus Z170-P D3/Corsair Vengeance LP 16gb DDR3(4X4gb)


New parts:
Asus Z170 pro gaming/Kingston HyperX Fury 2666 16gb DDR4(2x8gb)

Rest off my PC:
i7-6700k, CM 212 EVO, XFX R9 390x 8gb, EVGA Supernova 750W G2, Samsung Evo 840 250gb, SG Barracuda 1tb, WD Green 2tb

The problem:
After installation the new parts I booted straight to Windows 10 with no problems.

Everything seemed to work fine.
After that I shut down my pc to Movember it Back to my workstation. Since there was no ethernet cable close to the place where I assembled my PC.

I plugged on ethernet cable but nothing happened. There was only that red icon with white Cross.

What have I tried so far?

DRIVERS
I went to ASUS global and tried to install two different LAN DRIVERS for My motherboard.
I also tried to install never LAN driver straight from Intels side.


UEFI/BIOS
Updated UEFI tiistai newest one.

Other
Windows 10 reseted twice via control panel.

At the moment I'm tethering Internet from My phone.(Tethering via Xiaomi Redmi note 3)

This is how my device manager looks...

Any ideas?

Edit: sorry for typos. I'm on my way to work. Hence why I'm typing this post via phone.
 
Last edited:

trents

Senior Member
Joined
Dec 27, 2008
Sounds like the port is just bad. My wife has an Asus motherboard in her computer with a dead LAN port.

You have the choice of either returning the board for an RMA or purchasing an add on PCI-e LAN card. Not very expensive.

Many people on this forum will tell your that Asus is difficult to deal with for RMAs. Really bad customer service. And you will have to pay the shipping to them which would pretty much offset the cost of an add in LAN card.
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
It is possible you have a dead port on the board. Yep.

You are sure the port is enabled in the UEFI, righT? Have you tried disabling and re-enabling it through the device manager? Also, have you tried uninstalling the driver through device manager (right click uninstall)...then installing drivers from their website? What does it say when you try to install using any of the drivers you mentioned? Is it successful or does it fail?
 

mimart7

Member
Joined
Jun 6, 2011
Basic troubleshooting step:

Confirm that there is a blinking light on the RJ 45 cable where it is connected to the lan port. If there is no blinking light, swap the the cable.