• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Legacy Mode Doesn't Work

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

chrismtndew

New Member
Joined
Apr 26, 2016
I have an HP f305dx laptop that is currently running Linux Mint. I've tried to install Windows XP on it but no matter what I try, nothing seems to work. I've tried to boot from a CD and from a USB. When I boot from the CD, it actually kinda freezes my BIOS until I take it out of the CD drive, and when I try to boot from the USB, it'll either just give me a blinking cursor or say something like "No boot media detected. Insert disk and press any key." Any idea on why this happens? It happens even with legacy mode enabled and secure boot disabled. I know it's not the ISO I'm using as it works on other computers. Any input is appreciated.
 

mimart7

Member
Joined
Jun 6, 2011
Did this machine originally come with W10? If it did, you won't be able to install XP. You might be able to W7 to work on it, but that is unlikely. Reinstall W10, and run XP in a VM.
 

c627627

c(n*199780) Senior Member
Joined
Feb 18, 2002
Welcome to the forums.
Make an image of your hard drive because it contains hidden partitions where the factory image is located and your boot files are located. Do this so you can go back to what is already working.

If you want to experiment with something that can be a headache then you need to completely remove all partitions because Windows XP cannot be installed on a drive with a GPT partition table, modern laptops are set up on GPT because modern OS use this but Windows XP cannot.
You may know what all this means and if you do then good luck.
If you don't... then we need to talk basics first...
 

ITAngel

Member
Joined
Aug 1, 2012
Location
Wyoming
Personally I would buy a new blank drive, replace the entire drive so I put the original one on my safe. In case later on I want to sell the laptop I can restore back to factory and then sell. You can buy a cheap lic for Win7 and install that on the new drive. Make sure in the bios it is set to Legacy mode, may need to do a bios optimized option and safe.

I second what c627627 recommended. I have used GPT a lot in the past but for some people it may bet confusing.