• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Lenovo N500 no power

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

laci90

Registered
Joined
Oct 17, 2013
Hi, i have a lenovo n500 and it wont power on its actually really old but yesterday i tried cleaning its keyboards cause it wasnt working correctly because water entered in it and i tried cleaning it out but when i tried to plug in it powered and the fan was at max speed and no image but if i disconnected the keyboard everything worked fine except the touchpad so i tried plugging it back and i did now it doesn't even power on not even a sign of life no led nothing seems dead there is power in the power cable but it doesnt show that its plugged in so i don't have any idea what could be the problem
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
There isn't a period to be seen in the entire first post, LOL!

Sounds like you killed the laptop man :(. If unplugging and plugging back in the keyboard aren't helping, not sure what else you can do.
 
OP
L

laci90

Registered
Joined
Oct 17, 2013
but how did i kill it? before i plugged in the touchpad i snagged out the battery so it had no power and i didnt touch anything else or plug out anything it just doesn't start.the only led that is working is the battery charging led everything else seems dead
 

ATMINSIDE

Sim Racing Aficionado Co-Owner
Joined
Jun 28, 2012
Probably knocked water from the keyboard into the rest of the laptop.
 
OP
L

laci90

Registered
Joined
Oct 17, 2013
sorry i forgot to mention water didn't enter now it got into keyboard around 4 years ago i just decided to check if i can clean it or change the keyboard so i doubt that water got into the motherboard. and by water i mean rain
 

ATMINSIDE

Sim Racing Aficionado Co-Owner
Joined
Jun 28, 2012
Considering you're talking about a C2D era laptop it is most likely just dead from age...
 

HankB

Member
Joined
Jan 27, 2011
Location
Beautiful Sunny Winfield
I agree. But my T500 would not with the battery installed. I did not try it with the battery out. I bought a cheap battery on Amazon, ionstalled it and the laptop worked. The old battery had been deteriorating noticeably - providing at best a few minutes of operation without AC power.