• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Linksys Wireless-G Problems

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

sethmo

Registered
Joined
Jun 15, 2004
Alright I have a Linksys Wireless-G 4port Router. I have 2 computers wired up to it and they work fine and I also have 2 computers connected wirelessly with Linksys Wireless-G WMP54G PCI cards. But only one of the wireless computers can connect to the router. The other computer used to work, but I just reinstalled XP Pro on it and now it cannot see the router. I can manually add the router under the preferred networks but it will not connect to it. I have the drivers off the Linksys website and am using the windows wireless utility.

Anyone know anything I could be doing wrong?
 

Kendan

Senior Punk
Joined
Aug 27, 2001
Location
Dark side of hell
Make sure you are not running the Microsoft firewall and then disable the XP wireless utility and use the one from linksys. Once you get it working then you can go back and try to get the XP utility to work but it can be a pain:(
 
OP
S

sethmo

Registered
Joined
Jun 15, 2004
I cannot find the CD and the Utility wouldnt install with the drivers I downloaded. Is there any place I can d/l the utility from?
 

TimDgsr

Member
Joined
Jan 17, 2002
Location
Atlanta, GA
i used the xp utility with several linksys cards and had no problems with it. have you updated to service pack 1 with the one you just reformatted? I've had issues with pre-SP1 machines not connecting/seeing wireless networks properly.
 

Albuquerque

Member
Joined
Mar 26, 2003
Location
North America
If you have the router set to disable SSID broadcast, then the built-in WindowsXP wireless setup utility will not see it no matter what. Microsoft calls this a "feature", not a flaw. Stupid microsoft...

That was the issue I had with my DLINK setup at home. One of the very basic security methods is to turn off SSID broadcast, but doing so means you MUST have an OEM-supplied network connection manager software component. My Centrino-based Thinkpad R50 has absolutely no such software and is utterly dependant on the WinXp built-in utility, so I ended up having to turn my SSID broadcast back on.

But combined with WPA, no DHCP (static addressing) and MAC filtering, I'm pretty happy with the security :)
 

chittnp

Member
Joined
Jul 7, 2002
Location
Sandy Creek NY
I think TimDgsr is right, have you installed SP1? I have the same router and wireles card in my desk top and couldnt get them to work together untill I installed SP1.
 
OP
S

sethmo

Registered
Joined
Jun 15, 2004
I uninstalled it, then got all my updates from M$, then I reinstalled it but nothing. Maybe I am using the wrong drivers?
 
OP
S

sethmo

Registered
Joined
Jun 15, 2004
Alright I enabled the router to accept both G and B wirless and I install my old Wireless B card and it found the router just fine. I re-checked my Wireless-G card and it is in fact a WMP64G so the drivers are fine. Also, I am using the XP utility for the B card to access the router. Weird.
 

TimDgsr

Member
Joined
Jan 17, 2002
Location
Atlanta, GA
Albuquerque said:
If you have the router set to disable SSID broadcast, then the built-in WindowsXP wireless setup utility will not see it no matter what. Microsoft calls this a "feature", not a flaw. Stupid microsoft...

One of the very basic security methods is to turn off SSID broadcast, but doing so means you MUST have an OEM-supplied network connection manager software component.

actually, you can use the windows configuration utility and get onto a network with SSID broadcast disabled. i played around with it for a few hours, and figured out that once the ssid is off, windows can't recconect to it without rebooting. once i would reboot the machine it would connect to the network fine, even though the SSID wasn't broadcasting. However, if you have any sort of intermittent connectivity issues or you put your machine in stand-by very often, it is a little shotty and causes you to reboot your machine. That is the exact reason I just leave SSID broadcasting on. I ran WPA-PSK with mac filtering, but my cheap-o roommate bought some generic wireless card and for the time being i'm running 128wep with mac filtering.

as for the original discussion, I'm not sure what would be causing your g card to not work, other than configuration or improper driver :(