• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

List your losses to watercooling!

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Starfoxer

World's Biggest E-Thug
Joined
Feb 9, 2002
Location
USA
a nice UV Blue paint job on my mobo, whole case and all hardware soaked,

no deaths :p
 

bongo

Member
Joined
Sep 29, 2001
Location
Staten Island , NY
I think you guys should put in a disclaimer that states that most of the losses you guys had are soley caused by carelessness....etc.

I think this type of thread tends to scare people away from watercooling and makes stupid myths.....


im not saying i never killed any silicone, but.......:bang head
 

ATLPIMP

Member
Joined
Jun 30, 2002
I lost both of these and an Epox 8K3A+...
Actually, it was the Epox that killed both. I had the XP and Epox RMA'd, and the Duron was my loss (~$60). I figure, if I didn't have a water cooling setup, I wouldn't have messed with it, and it wouldn't have gone beserk. :beer:
The killing spree was not caused by any fault of mine, resulting in a leak... but it just up and went. :(

dead_CPU.jpg
 

BBigJ

Member
Joined
Dec 28, 2001
Location
Bay Area, CA
Three leaks, and no deaths. One leak lasted all day with the power on and got on the mobo, vid card, nic, and sound card. All survived after being dried and cleaned. And, yes, it was just carelessness.
 

Rushdie

Registered
Joined
Nov 15, 2001
Location
Sweden
A creative Voodoo2 12MB
A PII 233MHz
A Duron 800 (the clocked like hell... large loss)
A 2,3GB disk too :p
 

rogerdugans

Linux challenged Senior, not that it stops me...
Joined
Dec 28, 2001
Location
Corner of No and Where
My loss to watercooling at this point is about $230:D

Cost of my Swiftech kit. Been running about 9 or 10 months so far with no leaks or problems.

I have a home-brewed set up in the works that I mess with once in a while, but screwed up my almost complete block:( so that will be a while....
 

lebe0024

Member
Joined
Mar 22, 2002
Location
St. Paul - Minnesota
My roommate lost his athlon 800. But that's ok, the thing was a CRAPPPPY overclocker. It could only do ~950. My 750 T-bird did 1100 with a measily fop32.
 

Liss

Member
Joined
Aug 27, 2002
Location
Toronto: The Capital of Canada
the phone was lying next to my comp..

was moving something around.. tube came off.. out came all the water/antifreeze all over the table.. water got inside phone... water corroided inside phone... phone no work no more.. :(..
arg
 

JFettig

Hey! I showered! Senior
Joined
Jan 5, 2002
Location
MN
me either.............wait iv gotten water on a mobo and gfx card, no big deal, dried it off and such
 

Gravity Man

Member
Joined
Oct 4, 2001
Location
Edina, MN
I've never spilled a drop except when setting it up, and I didn't have anything in the case at that time, let alone turned on.