• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Max Boost Override having no effect?

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.
Joined
Oct 22, 2021
Hey all, I'm running a 5950x in an Asus Prime x590 Pro motherboard. For the past few weeks or so since getting this CPU I've been throwing myself into the deep-end of overclocking/tuning articles and YouTube videos. For the past several days I've been running this Core Cycler utility almost constantly, and I finally think I've got my PBO2 curve dialed in to the largest stable negative per-core offsets.

While tuning PBO2 I've left all other PBO settings at the basic defaults. PBO is enabled in each of the three(?!) bios menus that expose it and all related settings have been left at Auto with one exception - under the AMD Overclocking menu I set PBO Limits to "Motherboard" instead of Auto.

Now that I've got my PBO2 offsets tuned, my plan was to start increasing the Scalar and Max Boost Freq. I chose to start with Max Boost. I've spent the morning stepping through Max Boost Freq. from 0-200 in steps of 50 MHz, and running Geekbench, Cinebench R23 (Single and Multi), and 3dMark's CPU Profile benchmark for each step. So far, though, I've seen barely any change in scores (either positive or negative) aside from very very minor fluctuations that I think fall within the margin of error... Ryzen Master does reflect that the Max Boost Freq. has changed - for example, when I set Max Boost Override to +150MHz in the bios, RM shows each CCX as having a max freq. of 5.2GHz which is higher than it was when the override was 0MHz. However no core ever boosts higher than it did when I had the override set to 0MHz no matter how I measure it (clock speed and effective clock speeds).

I started trying a few things - I increased the EDC/PPT limits since RM showed my EDC maxing out. Those limits are now significantly high enough that they don't max out when running Cinebench R23 (PPT: 395 W, TDC: 250 A, EDC: 350 A). I also tried setting a positive CPU Voltage offset of +0.00625, and then +0.0125, but I didn't observe a change in frequencies after that, either.

I don't believe cooling is a limiting factor here (but I'm certainly open to someone telling me I'm wrong!)... I'm using an NZXT z73 with six Noctua NF-F12 industrialPPC-3000 PWM fans in push & pull configuration mounted to the front of my case as intake to pull in cooler air from the room. The maximum CPU temp I've seen during my testing so far was 81.5 C (reported by "CPU CCD1 (Tdie)" in HWInfo - "CPU CCD2 (Tdie)" maxes out at 78.5 C).

I can't figure out what's limiting me here. I understand that the silicon lottery comes into play and maybe that's whats happening here. But it bugs me that I'm unable to see any impact from adjusting the Max Boost Offset. It's like it's not even trying, or I'm hitting a limit that I'm unaware of.
 

freeagent

Member
Joined
Sep 15, 2004
Location
Winnipeg!
When I got my 5900X I did the same thing. Increased my limits to ungodly levels like that. Try lower.. try something like 200 PPT, 140 TDC, 180 EDC and work up slowly from there if you have to. I am running +150 and an all core curve of -30. I didn't bother with core cycler much.

Conversely, you can load up a hardcore program that will kick your CPU in the cores. Take note of its max PPT TDC and EDC, and apply those values in the overclocking section, and work the curve magic with those values.. that's probably what I would do after I tried the initial values I laid out :D
 

WhitehawkEQ

Premium Member
Joined
Dec 6, 2010
I think there is a typo here, ether you have a AMD MB or a Intel MB because I don't see a x590 on Asus website, Z590 is a Intel MB :)
I think you have a Asus Prime X570 Pro.

I don't have your CPU/MB but what I do on my systems is disable boost and just use the CPU multiplier and core voltage for overclocking.
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
Clearly a typo... he said 5950x two words in front of it so it has to be X570.

+1 to freeagents advice. Likely too much power in pbo. Or you can skip turbo all together like whitehawk does. Six of one, half dozen of the other...but of you're not griding all cores and threads in your workloads PBO is the best way to do it.