• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Maybe shutting down my 4P

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.
I have 14.04.02 LTS and did not have any issue with installing the client or control for 7.4.4.
 
I have 14.04.02 LTS and did not have any issue with installing the client or control for 7.4.4.

If you did an OS upgrade then the old stuff is still there, but a fresh install is missing certain old python parts. I remember being unable to install fahcontrol at all using 14.04 and so upgraded to 16.04 where the same problems still existed. It was solved in 16.04 by installing the old python and then installing fahcontrol directly instead of using the software installer built into 16.04.
 
Using the procedure outlined in my notes, have made at least a dozen fresh installs of 16.04.1 over past few months and no problem with fahcontrol after installing the python.

There is an opencl package I install to fix the FAH gpu slot ID issue on multi gpu systems and make the FAH gpu slot order match the order listed in nvidia-settings.

The reason I have been using the older 16.04.1 is that the kernel stays at 4.4.0-xxx, which allows the gui to work with the older, more efficient for folding, nvidia driver 370.28. The gui does not work with the newer kernels and the old driver.
 
If you did an OS upgrade then the old stuff is still there, but a fresh install is missing certain old python parts. I remember being unable to install fahcontrol at all using 14.04 and so upgraded to 16.04 where the same problems still existed. It was solved in 16.04 by installing the old python and then installing fahcontrol directly instead of using the software installer built into 16.04.

I never upgrade an OS, I always do full install, I did not install Python to get 7.4.4 to install and work with Ubuntu 14.04.02 LTS.
 
Hi All,

Quick update. The system seems to be running better now. It is picking up stuff in the 137XX family and now I am running at around 80k ppd. 40 minutes instead of 4 days...a big improvement.

FYI, I did install the python first, but FAHControl still does not work. It seems to be running better right now so I may just leave it like this till Gulp comes to visit next month...maybe he can fix it...he is much much more Linux saavy than I am.

Thanks for all the help!

Jeff
 
but FAHControl still does not work.

Still trying to understand your problem with FAHControl. Are there any error messages related to the install process or does FAHControl install OK, but fail to connect to the FAHClient?

I have seen "failure to connect to fahclient" message when the config file has more gpu slots than the host system has installed. For example, a gpu was removed from host system without deleting the FAH gpu slot first. Several ways to fix: delete slot first, manually edit the config file to remove the section for the extra gpu, or simply copy in a config file with correct number of gpus.
 
One other thing, I did not use the terminal to install the client and control, I used the GUI and double clicked on each file to install.

client_control.jpg

p.s. I did put 7.4.15 on 4P #2, on 4P #1 I have 7.4.4
 
Last edited:
Hi WhiteHawk,

When I start up FAHControl, nothing happens. No error messages or the like. When I clicked on the web link on the folding page, Ubuntu came up and offered to insatll, and I accepted.

I really appreciate your going the extra mile here...this has really frustrated me and no matter what I do, it does not want to work. I wish I had never upgraded from 12.04.

Jeff
 
Back