• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

MSI X58 Pro-E QPI Link Speed ( Is it safe to change it to Low Speed Mode ? )

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Vladimir1

Registered
Joined
Nov 8, 2015
Hi,

At the moment I have the QPI Link Speed set to High-Speed Mode but I was told that the high speed mode is only needed when you're using multiple great cards like 2x gtx 970s or more / better

So, in my case, I am using a GT 630 4GB DDR3 GPU which is nowhere near to be considered as a great card and I am wondering if it's safe to change the link speed to low speed ?
The reason why I wanna do that is because I think that having the option set to High-Speed Mode makes the IOH run on a higher temperature so having it run on a lower temperature would be a good benefit for me if there's no harm in changing this option ..

If someone can explain what exactly this option does, that would be great ..

Thank you
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
Leave it at the high speed.

QPI link is, more or less, the speed that things talk on the PC. I don't see a point in lowering it just to lower temps in the IOH.
 
OP
V

Vladimir1

Registered
Joined
Nov 8, 2015
I see .. Im thinking it might be worth a shot but on the other side I dont think my IOH temp is very high, on IDLE it's usually about 60-63C and at full CPU load it gets up to 70C, do you think there's nothing I should worry for ?