• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

MSI X99S Gaming 7 - Stuck on Code A9

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

JrClocker

AKA: JrMiyagi
Joined
Sep 25, 2015
TL/DR: If your MSI X99 Motherboard is stuck at A9 and won't post...power down, unplug ALL external USB devices except keyboard and mouse...let it boot.

I couldn't find anything on the internet, so I am posting here so folks can find it.


OK - yesterday I had the weirdest thing happen with my motherboard (MSI X99S Gaming 7).

- I took apart the machine to blow some dust out of the radiators
- While it was apart, I was like heck..I'll put in that Corsair Commander Pro and RGB Lighting kit I've had sitting around for a while
- I put everything together turn on the machine...

WON'T POST!!!!

- I'm like - well, maybe I'll be updating my PC sooner
- Determined to solve the problem, I remove my 2nd graphics card to expose the LED debug code thingy
- I boot the computer and it gets stuck at A9

- Googling around, I cannot find any meaning for A9 (I tossed my debug code printout I had created while I was putting the new desk in my office)

- I clear CMOS, it gets stuck at A9
- I remove all PCI cards except for main GPU, it gets stuck at A9
- I pull the battery, put it back in, it gets stuck at A9
- I remove and reseat memory, it gets stuck at A9
- I remove all but 1 memory chip, it gets stuck at A9

- At this point, I'm thinking it's either a bad motherboard or a bad CPU

- Thinking I'm done for the day, I unplug every external USB device except for the keyboard and mouse
- On a whim, I turn the PC on with 1 memory stick, 1 GPU, keyboard and mouse...the dang thing boots and I get into the BIOS screen!!!!!!

- I'm like WFT...really? My wife is like "I'm ready to go out for dinner"..."Almost done here!"

- I plug the remaining 3 memory sticks in...I turn the PC on with 4 memory sticks 1 GPU, keyboard and mouse...BAM...it boots and I get to the BIOS screen!!!!!
- Um...seriously...it just fixed itself?

- I figure "what the heck" and go for broke...I plug in the 2nd GPU and remaining PCI cards...
- I turn on the PC with 4 memory sticks, all PCI cards, keyboard and mouse...BAM...it boots and I get to the BIOS screen!!!!!


- Maybe something was loose...yeah that's got to be it...these things don't unbreak themselves


- I plug the remaining external USB devices in and turn on the PC...
- WTF...it hangs...won't post...

- WFT?!?!?!?!?!?!?


- With a process of elimination, I narrowed it down to my X56 Rhino joystick (not the throttle), when plugged in now, keeps my PC from posting...
- I tried it in EVERY USB port on the machine
- The X56 throttle is plugged into an external USB hub...I may do that for the joystick

- Can plug it in after it boots.
- I cannot have it plugged in on a reset or on a cold boot


A very weird "failure mode".

Cheers! :cheers:
 

trents

Senior Member
Joined
Dec 27, 2008
On the other hand, it's a simple enough just to unplug the existing device when you need to reboot and doing so doesn't require additional investment.
 
OP
JrClocker

JrClocker

AKA: JrMiyagi
Joined
Sep 25, 2015
I have discovered that if I run both joysticks through a hub I can leave them both plugged in