• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

need electrical help setting up bench psu!!

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Warlord2

Member
Joined
Mar 19, 2001
Location
Bakersfield,CA
ok I have a F24-12-A Power-One bench powersupply that I cant get working. (popping fuses)

I will tell you what is says

input: 100/120/215/230-240~
6.1/5.3/2.9/2.7A ~ ,47-63Hz
Output:----24v/12a or 28v/10a
derate 10% for <58Hz OPERATION

ok I know my house lines run at 110v, now does that mean I have to somehow lower it to 100v?

find some info on it
here the case is a F series.

thanks
 
OP
W

Warlord2

Member
Joined
Mar 19, 2001
Location
Bakersfield,CA
ok I will try the 120v

its just sorta weird to me that they would have it voltaged like that because houses are usually at 110,220,440 go figure:rolleyes:
 
OP
W

Warlord2

Member
Joined
Mar 19, 2001
Location
Bakersfield,CA
ok I just tryed both 100v and 120v jumper and both blew my fuse. What am I supposed to do with the ground wire? Ive been just leaving it alone. Also when I was testing it I setup a multimeter to it and my output read 19v thin slowly went down so Im thinking it does work, is it posible that my fuse box is too weak for the psu??? maybe I will try it on a 220v line.
 
OP
W

Warlord2

Member
Joined
Mar 19, 2001
Location
Bakersfield,CA
little bump.

anyone know if I need this ground ac wire hooked up to anything?? my hose fuses go up to 15amps so Im fine there. I just need to figure out how to hook this thing up I think.