• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!


Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.


Nov 25, 2019
United States

I wasn't exactly sure where to post this, due to there being numerous topics I need help with. But since these questions all revolve around me overclocking my memory, I figured this forum would probably be the best place to post.

So, anyway...I've recently been tweaking and testing out my new set of memory (Trident Z Neo - 3600 CL16 - Samsung B-die) and up until today I've been getting pretty good results as far as overclocking. I've successfully clocked the RAM from 3200 CL13 up to 3800mhz Cl16 and everything in between. But today, I decided to try and drop my 3800mhz clock down to 3733mhz to see if I could get tighter sub-timings by doing so. After about an hour I was able to successfully hit 3733 (16-16-16-16-34-52-358) and run a successful memory test using membench (in Ryzen DRAM calculator) to over 1200% (total).

Everything was looking good in CPU-Z. The timings were on point and the clocks seemed to be synced up perfectly...

But then I booted up HWiNFO64 just to double check my timings and clocks and that's when I noticed that my memory clock, memory controller clock (UCLK) and Infinity Fabric clock (FCLK) seemed to be slightly out of sync. I know how important it is to run your memory clock and IF clock at a 1:1 ratio, these 'un-synced' clocks are a bit of a problem.

My guess is that it has something to do with spread spectrum, due to the fact that my bus clock is also at 99.8mhz (not at 100.0mhz). But I'm not exactly sure how to disable spread spectrum in my bios. The DiGi+ VRM settings contain a Spread Spectrum option, but I can only access it if I switch my switching freq. to manual I believe. I also remember seeing an additional Spread Spectrum option somewhere in the bios (possibly under Advanced>AMD CBS>...) but Im not 100% positive.

The other possibility is this...

When setting my memory clock and IF clock in the bios (from the main AI Tweaker page) I selected 3733mhz for memory and 1866 for the IF clock. The issue is, that in order to keep the memory and IF clock in exact 1:1 ratio, I would need to set the infinity fabric to "1866.5" (technically), because that is exactly one half of 3733. But my bios does not have an '1866.5' option. It only has '1866'. But I just figured the bios (or motherboard) would be smart enough to know that I am trying to sync the 2 clocks and would make up for the additional "0.5" mhz. Apparently, that may not be the case...lol

So, here are my questions...

1) Do you think my clocks are ACTUALLY not synced properly? Or could this be a result of the software not correctly reporting the clock speeds?

2) If my clocks are indeed out of syn, how would you recommend I go about fixing them?

3) Is there any other way to check these clocks other than CPU-Z and HWiNFO64? I considered downloading Ryzen Master and using it to check the clocks as well, but I've had bad experiences using that awful software and would like to avoid putting it on my system, if at all possible.

4) How do I go about (safely) disabling 'spread spectrum' in the Asus ROG Strix X570-E bios?

5) What is the difference between the memory controller clock (UCLK) and Infinity Fabric clock (FCLK)? I was thinking these were both the same thing. But when I updated to the latest version of HWiNFO, I noticed they are 2 separate clocks apparently...?

Thank you in advance for any info/tips you may have for me.


Here are a few images showing my Membench, CPU-Z and HWiNFO64 results...


This behavior is normal. Being in sync exactly doesn't have anything to do with the ratio and gearing down of FCLK to memory. When it desyncs, it goes to 1:2 and not a minuscule amount off due to natural spread spectrum. When you run multiple pieces of monitoring hardware together, that can cause some issues too. It all runs off the same 99.8 (or whatever it may be) bclk.
ahhh i see... you know, i think ive heard that somewhere before...that if you run multiple montioring tools with Ryzen, it tends to casue the sensors/redings to malfunction. derrrp i cant believe i didnt think f that! lol so you think my 3733mhz memory overclock is okay then? sorry for all the dumb questions. this is my very first time overclocking/tweaking a ryzen 3000 sysetm. also my first time using an X570 motherboard. im still learning how exaclty to fine tune my new system.

thank you for the reply!

PS - while i have your attention, can i ask you 1 more question, since you seem to to be pretty knowledgeable?

i just thought about is the fact that I have disabled "High Precision Event Timer" (HPET) in device manager, as well as disabled all other synthetic timers from the command prompt. I also use 'Timer Tool' to set my own custom timer resolution (typically '0.5'). Do you think this may play a role in my strange monitoring software readings? Or does HPET not effect on-board sensor readings?

Disabling HPET is what worked best for gaming/overall performance on my Ryzen 2600X/B450 Tomahawk setup. So, I figured I would do the same thing on my new 3700X/X570 system. Is it still advised to disable HPET for Ryzen 3000 and X570 systems? Should I still be disabling these synthetic timers and setting my own custom resolution using Timer Tool?

I haven't been able to find any definitive answers on this topic.