• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Need some GF2 MX400 help!!111

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

CM123

Registered
Joined
Apr 8, 2002
Location
Sweden
Ok first of all here is my computer specs.

Abit KT7A-Raid
Thunderbird 1.2 ghz
512 mb sdram
Geforce2 MX400
Windows 2k Pro

I have always been using opengl since its usualy the fastest way to play games, but one day it just stopped working, no idea why. The game im usualy playing is half-life (or rather one of the mods for it, in this case CS), i started it as usual (hadnt changed anything since the last time it worked, no new drivers or anything) and it said that "this opengl mode is not supported by your videocard" , i was really puzzled so i tried reinstalling the drivers but that wouldnt work at all, same error. Then i tried using other version of the detonator drivers which i use, but that didnt help. I then formated my hd (last hope...) and reinstalled windows 2k pro, installed HL and CS and started it....and what do i see.... "this opengl mode is not supported by your videocard" , at this point i was more or less ****ed off, i even tried playing in Windows XP (secondary OS on my other HD) but same error there.

I then checked the opengl32.dll file in the windows/system32/ folder and i saw that the version was all wrong, instead of a new version of the file, it was version 5.0.2195.4709 , which ive heard is the default driver in windows (???) , i then tried copying a new version of the file there but seconds after i did that the file got "changed" back to the default one. Now why does it replace it with a version that doesnt even work???

please people...begging here...CS barely works in direct3d and who would want to play in software mode......help...
 

cullam3n

Member
Joined
Apr 25, 2002
Location
San Antonio, TX
Did you accidentally click on "3dfx mini drivers" on the left side bar by mistake and not the regular OpenGL drivers? Does this happen in other games?

-PC
 
OP
C

CM123

Registered
Joined
Apr 8, 2002
Location
Sweden
Opengl will not work in ANY game, and no i didnt use the 3dfx driver, i even tried to copy opengl32.dll to the gldrv folder in half-life but nothing works

i think its because windows 2k replaces the "real" opengl driver with a default one, but i have no idea how to prevent it from doing that

the real driver is 2.5mb and its from october this year, while the default one is....ooold.......and its only 667kb big (if that matters at all)

does anyone have any suggestions?
 

cullam3n

Member
Joined
Apr 25, 2002
Location
San Antonio, TX
I would go download some drivers from nvidia's website, and make sure that in the device manger there are no conflicts concerning the video card.

-PC
 
OP
C

CM123

Registered
Joined
Apr 8, 2002
Location
Sweden
already done that, problem is as i stated, that windows replace the opengl32.dll file with a old version, so it dont matter what driver i install since it replaces it anyway. i gotta prevent it from replacing it somehow.....
 

quegyboe

Member
Joined
Dec 20, 2000
Location
BC Canada
Sounds to me like you have non-WQHL certified drivers. Try downloading the certified drivers and see if that helps....
 
OP
C

CM123

Registered
Joined
Apr 8, 2002
Location
Sweden
Tried that as well, installed the latest detonator drivers which is Version: 30.82 and they are WHQL Certified

Problem is it replaced the new opengl32.dll again with something that wont work.......gah im gonna kill myself soon....
 
OP
C

CM123

Registered
Joined
Apr 8, 2002
Location
Sweden
Windows 2000 Professional, Service Pack 3 (5.0 - 2195) is what im using
 

Lancelot

Member
Joined
Feb 12, 2001
Location
the Netherlands
Half-Life needs a patch to run reliably under win2k and XP, you can download it at sierra.com, it's a good bet this solves your open-gl issues.
 
OP
C

CM123

Registered
Joined
Apr 8, 2002
Location
Sweden
Been trying to find that patch, no luck so far. Only patches ive been able to find is the regular ones. Cant find anything related to windows 2k at all

any hints? :)
 

cullam3n

Member
Joined
Apr 25, 2002
Location
San Antonio, TX
Lancelot said:
Half-Life needs a patch to run reliably under win2k and XP, you can download it at sierra.com, it's a good bet this solves your open-gl issues.

I don't think that's true unless 1.1.1.0 contains that patch.

-PC
 
OP
C

CM123

Registered
Joined
Apr 8, 2002
Location
Sweden
ok, i found the drivers cache and fixed so it dont auto install the default drivers, i then installed Detonator 40.72, but i still get the "opengl not supported" error message...argh.....
 

cullam3n

Member
Joined
Apr 25, 2002
Location
San Antonio, TX
CM123 said:
ok, i found the drivers cache and fixed so it dont auto install the default drivers, i then installed Detonator 40.72, but i still get the "opengl not supported" error message...argh.....

Cache? Who are you?

Hmm.. I really don't know what the problem is.

-PC