• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

New build has stutter/fps lag on videos, gif's, games, everything feels slow

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Kaoskrewpb

Registered
Joined
Aug 20, 2013
Location
Arizona
Fresh install of Win7 Home 64 bit
I've installed Chipset drivers, Ethernet drivers, Geforce experience and updated drivers through it, and all windows updates

Also - Shockwave Flash crashes very often when watching movies or videos, even thought I have the newest player installed on chrome.

Been trying to narrow down this problem with my new build and I just can't figure it out. I don't know enough to diagnose it.

Basically everything video wise feels like it has FPS/stutter lag. (We're talking even Runescape has lag)
Youtube videos, GIF's, Runescape, csgo, battlefield. everything.

I have swapped out the GPU to a GTX 960 to see if it was a gpu problem, but it wasn't.

Nothing is overclocked
My specs are:
GTX 980
Z170 S Sabertooth
Ballistix Sport LT 16GB Kit (8GBx2) DDR4 2400 MT/s
i7 6770k
H80i Water cooling
Kingston 240 gb SSD

Any help would be fantastic
 
Last edited:

wingman99

Member
Joined
Dec 10, 2003
What Chrome version do you have? I have problems with Adobe Flash Player in windows 10 IE 11. Do you have the newest Drivers for USB?
 
OP
K

Kaoskrewpb

Registered
Joined
Aug 20, 2013
Location
Arizona
What Chrome version do you have? I have problems with Adobe Flash Player in windows 10 IE 11. Do you have the newest Drivers for USB?


Yes I have the latest USB drivers

Here's what I get when i type Chrome://version in the address bar

Google Chrome 51.0.2704.103 (Official Build) m (64-bit)
Revision aa7c8d23c098e96a388ffedf6698230bda650bb3-refs/branch-heads/[email protected]{#723}
OS Windows
Blink 537.36 (@aa7c8d23c098e96a388ffedf6698230bda650bb3)
JavaScript V8 5.1.281.65
Flash 22.0.0.192
 

wingman99

Member
Joined
Dec 10, 2003
Looks like you have the newest Chrome version. The one thing you can try is removing all the devices also drives that you can to see if you have a conflict. Also if you have a spare hard drive or SSD try running your PC off it, a bad drive also cause lag or slow perforamce, you can also do a drive test.
 

Evilsizer

Senior Forum Spammer
Joined
Jun 6, 2002
double check temps to make sure you got a good mount, as it is possible throttling is going on.