• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

New Build, no beep?

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.


Dec 7, 2013
New Build:

PCPartPicker part list / Price breakdown by merchant / Benchmarks

CPU Cooler: Noctua NH-U12S 55.0 CFM CPU Cooler (Purchased For $64.99)
Motherboard: Gigabyte GA-G1.Sniper A88X ATX FM2+ Motherboard (Purchased For $102.49)
Memory: G.Skill Ripjaws X Series 8GB (2 x 4GB) DDR3-2133 Memory (Purchased For $76.50)
Storage: Samsung 840 EVO 250GB 2.5" Solid State Disk (Purchased For $199.99)
Storage: Western Digital Caviar Blue 1TB 3.5" 7200RPM Internal Hard Drive ($59.98 @ OutletPC)
Wireless Network Adapter: D-Link DWA-171 802.11a/b/g/n/ac USB 2.0 Wi-Fi Adapter (Purchased For $29.99)
Case: Nanoxia Deep Silence 2 ATX Mid Tower Case (Purchased For $89.99)
Power Supply: Corsair Professional 750W 80+ Gold Certified Semi-Modular ATX Power Supply (Purchased For $122.49)
Optical Drive: Asus DRW-24B1ST/BLK/B/AS DVD/CD Writer (Purchased For $16.99)
Operating System: Microsoft Windows 8.1 Pro - 64-bit - OEM (64-bit) (Purchased For $0.00)
Keyboard: Logitech K350 Wireless Ergonomic Keyboard (Purchased For $39.99)
Mouse: Logitech M570 Wireless Trackball (Purchased For $39.89)
Other: A10-7850K (Kaveri) - Estimate ($200.00)
Total: $1043.29
(Prices include shipping, taxes, and discounts when available.)
(Generated by PCPartPicker 2014-01-18 11:23 EST-0500)

I have tried everything I can think of. I am thinkings its a DOA mobo, but not sure. Maybe someone has some other things I can try before I RMA the mobo on my current hunch.

I am trying the basics. The mobo is on the AS bag on a box, 1 stick of the new 2133 RAM, stock cooler w/ thermal paste, and the new PS. I have a case/beep speaker plugged in and a monitor. Both the 8pin and 24 pin power supplies are connected.

  • I have reseated everything multiple times.
  • I tried a known working PS w/ same results.
  • I tried multiple monitors and connections w/ same results.
  • I tried both sticks of ram and all ram slots w/ same results.
  • I have some old 1066 RAM, but the mobo doesnt list it as compliant, so I didnt want to ruin it (its in use in another PC).

If I put no RAM in, it will give a long steady beep. Aside from that, I have heard no beeps.

What should I do to confirm its part A vs. part B?
Yeah, was worried about the new P6T I7 920 I built over the weekend I bought, thought I saw a few bent pins on it at first but after looking they were fine.

Ya have to watch for those a bit.
Does it boot at all?

I mean do you see a splash screen or an option to load into the bios?

It might be that the bios is default set to legacy ide vs. ahci which is needed to run a SSD.
Its brand new, so nothing has beein installed anywhere - there is no windows to boot into, just a new SSD which is not even connected now.

I did check for bent pins but they are all ok as best I can tell.

I see nothing - it doesnt boot at all - no splash screen, no bios, no nothing. Nothing changes on the screen, the monitor just has a continuous "no signal". I tried multiple monitors using all possible connections to the MB and all had the same results.

The processor is a new A10-7850K (Kaveri).

I tried just the basics - CPU w/ cooler&fan, 1 stick of RAM, known working PS, both power connections to mobo (8 & 24), and a monitor. No POST - still nothing on the screen. This eliminates the SSD.

I tried buying a new stick of RAM on the odds that the two I had were both defective and it didnt change anything. I tried each stick I have (3), one at a time in each slot (4) and had the same results. I think this eliminates the RAM (or makes me VERY unlucky).

I think trying a known working PS removes the PS.

In my book, its down to the mobo or cpu. I am under the impression that its more likely the mobo, so I am going to RMA it.
I am trying just the basics... Mobo, CPU+HS, 1 stick of RAM, PSU, onboard video (it's an AGP).

Powering on, there is no beep.

I checked for bent pins - all seem fine.

This is mobo #2 - so probably not the Mobo.

I tried two different sticks of RAM - so probably not the RAM.

I tried a known working PSU - so probably not the PSU.

Cleared the CMOS.

Do I RMA the APU at this point?
Don't test the board on the anti-static bag. The exterior of the bag is conductive. ;)

Bet it was shipped with a bios that doesn't support Kaveri. Needs to be flashed.
Last edited:
I called gigabyte and they say the bios needs to be updated. Unfortunatly, I dont have an FM2 processor I can use to update it so I will need to RMA it to them to update it. Crazy. Very sad :(