• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Newcomer questions.

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Adak

Senior Member
Joined
Jan 9, 2006
The "warning: could not delete all work unit files", is bogus - you'll see that all the time, and it's wrong - because 5 seconds later, it does delete all the files it should be deleting.

Stanford considers this a "cosmetic issue", and has put fixing this, on the back burner.
:mad:

The servers you tried are working - if you click on the url you'll see an "OK" reply.

So I'm guessing you haven't yet listed fah's client as an exception in your firewall's exception table, perhaps?

For Windows, it's: Start>>Control Panel>>Security Center>>Firewall>>Exception Tab>>Add a program. Whew! :D

Programs to add:
fah6.exe (I have renamed my fah executable "fah6.exe"). Use your fah executable's real name, of course).
mpiexec (I have 4 of these, you may need less)
smpd (I have 2 of these, you may need fewer)

Also, there is a checkbox you should mark: Says "Display a notification when Windows Firewall blocks a program." Be sure that is checked. You need to know if the firewall doesn't like some new client.

Let me know if that isn't the problem (the firewall), and I'll dig into your log files and etc., later this afternoon.
 

Outback_Jon

Member
Joined
Feb 21, 2009
Location
[email protected] in Greene County, NY
"- Warning: Could not delete all work unit files (2): Core returned invalid code";
This happens sometimes. It's a known "feature" of the SMP client.

Code:
[12:19:19] Completed 30000 out of 250000 steps (12 percent)
[12:24:33] Gromacs cannot continue further.
[12:24:33] Going to send back what have done.
[12:24:33] logfile size: 31626
[12:24:33] - Writing 32162 bytes of core data to disk...
[12:24:33] ... Done.
[12:24:34] - Failed to delete work/wudata_05.sas
[12:24:34] - Failed to delete work/wudata_05.goe
[12:24:34] Warning: check for stray files
[12:24:34]
[12:24:34] [email protected] Core Shutdown: EARLY_UNIT_END
[12:24:34]
[12:24:34] [email protected] Core Shutdown: EARLY_UNIT_END
[12:24:36] CoreStatus = 7B (123)
[12:24:36] Sending work to server
[12:24:36] Project: 2665 (Run 3, Clone 926, Gen 66)
EUE's happen. :D They aren't too common on SMP, but they're more common if you're running -advmethods, but they do occur. All the usual suggestions: If you're overclocking, back it down. Check your temperatures. etc.

Code:
[05:06:59] + Attempting to get work packet
[05:06:59] - Will indicate memory of 2046 MB
[05:06:59] - Connecting to assignment server
[05:06:59] Connecting to http://assign.stanford.edu:8080/
[05:07:20] - Couldn't send HTTP request to server
[05:07:20] + Could not connect to Assignment Server
[05:07:20] Connecting to http://assign2.stanford.edu:80/
[05:07:41] - Couldn't send HTTP request to server
[05:07:41] + Could not connect to Assignment Server 2
[05:07:41] + Couldn't get work instructions.
[05:07:41] - Attempt #15 to get work failed, and no other work to do.
Waiting before retry.
[05:08:52] - Autosending finished units... [March 29 05:08:52 UTC]
[05:08:52] Trying to send all finished work units
[05:08:52] Project: 2653 (Run 18, Clone 32, Gen 142)


[05:08:52] + Attempting to send results [March 29 05:08:52 UTC]
[05:08:52] - Reading file work/wuresults_01.dat from core
[05:08:52] (Read 5535525 bytes from disk)
[05:08:52] Connecting to http://171.64.65.64:8080/
[05:09:13] - Couldn't send HTTP request to server
[05:09:13] + Could not connect to Work Server (results)
[05:09:13] (171.64.65.64:8080)
[05:09:13] + Retrying using alternative port
[05:09:13] Connecting to http://171.64.65.64:80/
[05:09:34] - Couldn't send HTTP request to server
[05:09:34] + Could not connect to Work Server (results)
[05:09:34] (171.64.65.64:80)
[05:09:34] - Error: Could not transmit unit 01 (completed March 29) to work server.
[05:09:34] - 3 failed uploads of this unit.
Looks like your firewall doesn't like the SMP client. Just to be sure, you do have a password set up for Windows, and you entered it in when setting up the SMP client, right?

Once, FahMon stated *Hung* or something like that. I restarted the client (using ^C of course), but later inspection of the logs showed that there was nothing that indicated hanging..
FAHMon does this from time to time. It even shows up on my wife's computer as "Hung" when the computer is running nothing but Folding. I've solved the problem by ignoring it. :D
 
OP
S

swooboo

Registered
Joined
Mar 22, 2009
I am sorry to get the old thread started again, lately, I have no problem with connecting, but rather a problem with EUEs.. I've had 2 or 3 of these lately, and I am not overclocking.. I don't really have the knowledge to overclock, and I don't use any monitoring programs. I think my E8650 is not running it's full 3ghz though.. Any help?

And I would be more than happy if someone would be kind enough to mentor me, so I could bug him with all my questions..:santa:

P.S. I forgot to mention that all EUEs happend on P2665, it has 1920 points, and my PPD always drops from 1700 to 1400 on that one..
 

Jolly-Swagman

Member
Joined
Sep 20, 2007
swooboo in your Bios have you got EIST and C1 disabled,

yeah the P2665 are a bit of a punisher when it comes to WU,s and do take a little longer to complete,

You may want to put some System specs up in your Sig area so as to make it easier for us to help, knowing what type of complete system, you have,

Feel free to PM me, if needed as a Mentor.
 
OP
S

swooboo

Registered
Joined
Mar 22, 2009
Ok put the specs in the sig, hope this is enough. I disabled both C1 and EIST, is that right or you wanted it to be enabled?

Thanks!
 

Adak

Senior Member
Joined
Jan 9, 2006
To fix the Windows firewall:

Start >> Control Panel >> Security Center >> and click on "Manage Settings for Firewall"

On the first page, you need to be sure the check box next to "Don't Allow Exceptions" is cleared, and the firewall is active.
Then click on the "Exceptions" tab, and add mpiexec, smpd, as well as the fah executable file name, to that exception list.

Then click on the "Apply" button, and exit.

All the "green" or power saving options in your BIOS, should be disabled. Also, your power saving options in your OS, should be set to slow down your computer >> never.

Two area's for Windows are: Control Panel >> Power Saving and Control Panel >> Display Options. Even a screensaver can cause folding to nearly stop, because FAH will yield it's cpu cycles, to almost every other program.
 
Last edited: