• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

newegg RMA's?

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

shauns

Member
i bought a 100gig wester digital from them got it yesterday, and i pluged it in a BANG it made the loudest noise ive ever heard a HD make. a big CLUNCK and click click click, so i sent a rma to newegg, no status yet, i just wanted to know if anybody has had a problem w/ new egg and RMA's?
 

Jon

Just Another Retired Moderator
Joined
Dec 19, 2000
Location
Lawrenceville, GA
I've sent 2 RMAs to them and was done right both times.

The last one was for my VP6 that mysteriously died. They couldn't repair it and didn't have a refurb for replacement so they credited me back what I bought it for originally. $135 back even though I bought it about 8 months ago. Funny thing is that I only sent them the board and box. I kept all cables, manual, extra USB cable and CDROM...they didn't ask for them back and I didn't see it necessary to send them since it was a "Repair Only" option.
 

tainice

Member
Joined
Oct 20, 2001
Location
Carbondale, IL
Free cables for u:) anyway, i do think their ram is somehow sucky sucky...i ram my 350w sparkle back for low 12v line, and i think i got the same one back...:( or i simply got two sparkles with the same readings! (both checked with voltmeter..report the same thing..) Gor-sh that'z lots "same";)