• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

not sure if this is specific to intel combos: Can't see motherboard boot screen when main display is connected to my 980t

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

mrjayviper

Registered
Joined
Jul 18, 2012
as above. If I switch to iGPU (via HDMI), no problems. Suggestions? Thanks

setup: Gigabyte z590/11400 with iGPU set to enabled (I've tried auto and disabled and it makes no difference)
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
980 Ti? Are you referring to the splash screen for the mobo? Does it boot ok otherwise? I see those splash screens with my Intel rigs...

Hmm, good one. If you hit tab starting when you press the power button, does it show the POST details?
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
That's a good point. Although I have NVMe M.2 sticks, on most boards I still see it. When I don't it's typically after a first reboot or something.

That reminds me, bug.... viper, see if fast boot is enabled in the bios...if so, disable.
 

mrjayviper

Registered
Joined
Jul 18, 2012
980 Ti? Are you referring to the splash screen for the mobo? Does it boot ok otherwise? I see those splash screens with my Intel rigs...

Hmm, good one. If you hit tab starting when you press the power button, does it show the POST details?
I can press delete/f2 all I want and the screen is still blank
Post magically merged:

Are you using an SSD? My laptop boots so fast I don't see the splash screen most of the time. Can you get into the BIOS?
If that's the case, then why can I see the motherboard boot screen when on iGPU (same drives/SSD)
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
I said the TAB button...del/f2 is to get you into the bios.

Did you check to see if fast boot was enabled? If so, disable and try on dGPU again.

There's also a setting to delay boot options (both should be in boot section)... raise that value to 3+ seconds.


For boards that do this, I just look at the numlock led on my keyboard...the instant it lights up, I'm banging the delete key. Works for me.
 

grumperfish

Member
Joined
Nov 10, 2005
If you have the CSM enabled in BIOS, turn it off. My Gigabyte board was doing that for a bit until I realized that was the cause.