• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Nvidia sli HB bridge not being detected by the control panel

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Mikesamo

Member
Joined
Jun 10, 2014
Location
san jose CA
hi forum i recieved my hb bridge by mail to replace my 2 flex bridges and there seems to be a problem . i put the bridge properly on my 2 1070s and it lights up green but it doesnt show on the control panel . what could be the issue here UPDATE
please disregard . it appears that the latest drivers dont make it work for some reason . i used an older one and it works okay now
 

dominick32

Senior Solid State Aficionado
Joined
Dec 19, 2005
Location
New York
I'll give you the early results brother! Lol
HIGH BANDWIDTH BRIDGE = Identical Performance to using 2x traditional flex bridges.
 

dominick32

Senior Solid State Aficionado
Joined
Dec 19, 2005
Location
New York
The results really should be identical to be honest and assuming other hardware , clocks, or benchmark variation hasn't changed . Here's one review that I can remember off the top of my head. Check the hardwsre unboxed review here: https://www.youtube.com/watch?v=mWcsaociTjE
He tests dual flex bridges versus a single Nvidia HB Bridge and had identical results in all games to the exact numbers . There are other full reviews as well that experience the same phenomenon .
 

dominick32

Senior Solid State Aficionado
Joined
Dec 19, 2005
Location
New York
It looks pretty cool though? It's like using those Honda horsepower stickers on your car . I'm sure someone running a 1080 set up will drop the coin on this just to say they have the HB bridge ! I am going to use the free cheapo SLI bridges that came with my motherboard ! Lol ;)
 
OP
Mikesamo

Mikesamo

Member
Joined
Jun 10, 2014
Location
san jose CA
It looks pretty cool though? It's like using those Honda horsepower stickers on your car . I'm sure someone running a 1080 set up will drop the coin on this just to say they have the HB bridge ! I am going to use the free cheapo SLI bridges that came with my motherboard ! Lol ;)

sure does . my only issue is the unchangable green led which you can turn off. the rest of my system is black and white