• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

OCZ Agility 3 60Gb setup, review and benchmarks

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

TyrAntilles

Registered
Joined
Jan 28, 2010
SSD on AHCI mode and 3 HDD's on RAID 0 ARRAY on the same controller. OCZ Agility 3 60Gb setup, review and benchmarks.

I recently bought my first SSD, namely OCZ Agility SATA 3 of 60 Gb, even if my motherboard have only SATA 2 because, frankly, it was the cheapest SSD in my area with a capacity of at least 60 Gb. My target is to install on it the OS (Windows 7 x64) and the most common used programs. I am very curious how it will perform in comparison with my actual RAID0 made of 3 WD Caviar black of 1 TB.

I just bought a new SSD for my computer and I am going to test it out.

- HARDWARE:
o MB Gigabyte P55-UD3 (BIOS version: F9)
o CPU Intel Core i5-750
o CPU Cooler Scythe NINJA MINI rev B (SCMNJ-1100)
o RAM Kingston DDR3 8 GB 1600 MHz KHX1600C8D3K2/4GX (CL8) (4x2Gb)
o SVGA Sapphire Radeon HD 4670
o SSD OCZ Agility 3 60Gb (SATA3 SSD set on SATA2 mode)
o HDD Western Digital WD1001FALS (RAID 0 member 1)
o HDD Western Digital WD1001FALS (RAID 0 member 2)
o HDD Western Digital WD1001FALS (RAID 0 member 3)
o DVD-RW – ASUS DRW 1608P
o DVD-RW Sony Optiarc AD-5240S-0B
o CASE Lian li PC-K7B
o PSU Fortron Blue Storm II 500 (with cooler Gentle Typhoon)
o Monitor Horizon 2206SW - 22" LCD
o OS Microsoft Windows 7 Home Premium 64 bit English OEM


- FINAL BIOS SETTINGS
******************************************
Hard Disk Boot Priority

1. SCSI-1 : OCZ-AGILITY3
2. Bootable Add-in Cards
3. SCSI-0 : Intel JaneRAID1
******************************************
Integrated Peripherals

eXtreme Hard Drive (XHD) [Disabled]
PCH SATA Control Mode [RAID(XHD)]
SATA Port0-3 Native Mode [Enabled]
USB Controllers [Enabled]
USB Legacy Function [Enabled]
USB Storage Function [Enabled]
Azalia Codec [Auto]
Onboard H/W LAN [Enabled]
Green LAN [Disabled]
SMART LAN [Press Enter]
Onboard LAN Boot ROM [Disabled]
Onboard SATA/IDE Device [Enabled]
Onboard SATA/IDE Ctrl Mode [IDE]
Onboard Serial Port 1 [Disabled]
Onboard Parallel Port [Disabled]
x Parallel Port Mode SPP
******************************************
Here the two main controllers of this motherboard can be set, the Intel SATA controller (6 ports) and a JMicron controller added by Gigabyte (2 ports).
PCH SATA Control Mode. This is the Intel SATA controller set on [RAID(XHD)]. This allow me to keep my RAID0 array while handling the SSD in AHCI mode in the same time.
Onboard SATA/IDE Device [Enabled]. This handles the Gigabyte's JMicron controller and ATA 100 devices. Since I have here only the ASUS DRW 1608P ATA 100 DVD Writer, I set this on IDE mode.

********************************************

First I installed the SSD on one of the two ports of the second controller (JMicron), in order to update firmware if necessary and to test it on this controller in AHCI mode, because I wanted to keep my existing RAID0 array for the Intel controller before making it a boot drive. My first concern was to be sure the SSD is running in AHCI mode and with TRIM enabled. My motherboard, a Gigabyte GA-P55-UD3 have two SATA controllers, Intel from the MB chipset (6 SATA) and a JMicron controller added by Gigabyte (2 SATA).
I've read on different forums that JMicron is a lot slower then Intel one, but Intel controller being set on RAID mode I decided to install the SSD on JMicron just to try it out (I didn't know Intel support AHCI and RAID in the same time, I only found out later that if Intel controller is set on RAID mode it will apply RAID for the HDD's defined by the RAID array and AHCI for the devices non-members of the RAID array). So, I left the Intel Controller on RAID and enabled AHCI for JMicron Controller on BIOS.

I rebooted without installing anything on the JMicron and on Windows just ran in the first problem: Core 3 of my i5-750 CPU was utilized 80% even on idle, by a hardware conflict. Digging deeper I found on Device Manager the SATA controller without drivers. Couldn't update it from Mirosoft I took a look on my motherboard drivers and found "GIGABYTE SATA2 Driver v.1.17.59.0". After installing this, the conflict disappeared instantly (even before reboot) and the problem was solved. My CPU is now 0-2% loaded on each core when in Idle, which is just as it should be.
Shutdown, installed the Agility 3 SSD on one of the two JMicron SATA ports, start Windows and SSD was detected from the begining. Went on Disk management and Quick format it on NTFS. From this point it was good to go.

CrystalDiskMark v.2.2 (SSD OCZ Agility 3 60Gb on JMicron controller, AHCI and TRIM enabled):
SEQ = 120.0 , 79.0
512K = 115.6 , 79.49
4K = 15.35 , 29.36


HD Tune v.2.55 (SSD OCZ Agility 3 60Gb on JMicron controller, AHCI and TRIM enabled):
Transfer rate:
MIN: 78.7
MAX: 108.5
AVG: 107.2
AccTime: 0.1
Burst: 2344.5 (this is obviously an error)
CPU: ~error~
J64b_SSD_HDTune%252520on%252520AG3%252520%252528JMicron%252529.png

As a comparison here are the results of the same tests for my RAID 0 first partition:

CrystalDiskMark v.2.2 (Intel RAID 0 array with 3 WD1001FALS 1Tb):
SEQ = 292.2 , 210.1
512K = 74.72 , 236.5
4K = 1.552 , 5.550

HD Tune v.2.55 (Intel RAID 0 array with 3 WD1001FALS 1Tb):
Transfer rate:
MIN: 124.1
MAX: 204.5
AVG: 171.7
AccTime: 6.8
Burst: 106.9
CPU: ~error~

I can't wait to find out if, in the day by day use, the SSD will feel faster or slower then the RAID.

I run OCZ Toolbox to check the drive settings and configuration, and surprise, the SSD wasn't detected on JMicron controller, the OCZ Toolbox said is no detected OCZ SSD on the system even if the Toolbox was started right from the SSD. So much for the JMicron, shutdown and changed the SSD to Intel controller from mobo chipset as a secondary drive.

CrystalDiskMark v.2.2 (SSD OCZ Agility 3 60Gb on INTEL controller, AHCI and TRIM enabled) (run 1):
SEQ = 201.9 , 78.29
512K = 187.7 , 78.76
4K = 16.68 , 58.23
J64b_SSD_CrystalDiskMark%252520run1%252520%252528Intel%252529.png

HD Tune v.2.55 (SSD OCZ Agility 3 60Gb on INTEL controller, AHCI and TRIM enabled):
Transfer rate:
MIN: 56.5
MAX: 170.2
AVG: 146.1
AccTime: 0.2
Burst: 118.4
CPU: ~error~
J64b_SSD_HDTune%252520on%252520AG3%252520%252528intel%252520run1%252529.png

I found out that the transfer rate is strangely uneven on INTEL controller unlike on Jmicron. I have no idea why.
Here is other measurement I made later, with the same test but this time with Windows 7 x64 installed on SSD and running from SSD:
J64b_SSD_HDTune%252520on%252520AG3%252520%252528intel%252520run5%252520after%252520NewWin1%252...png


Now, getting back at the version of windows running from RAID HDD's with SSD installed as a secondary drive on Intel controller. I wanted to check again the OCZ Toolbox and this time it was working:
J64b_SSD_OCZToolboxMP_AG3%252520firmware.png

I was happy to see that it have the latest firmware version at this time (2011.12.29), namely v.2.15. No need for update.

Now I gathered some information in order to verify if drive alignment is correct, if AHCI mode is truly activated and if Trim is working properly. Thanks to [LYL]Homer from [H]ard|Forum who said:
"Note that AS SSD reports the drive as using the 'iaStor' driver when in AHCI mode and 'pciide' when in IDE mode.
AS SSD also shows if your drive is aligned correctly under that by reporting 'OK' in green or 'BAD' in red. If you have installed under Win7 it will align automatically for you and should be ok. The easiest way to align an XP install is to hook the drive up temporarily to a Win7 box and make a partition and format it. Then when in your XP install choose the "use existing file format" option."

So here is AS SSD for me with new Windows 7 x64 without any updates:
J64b_SSD_AS%252520SSD%252520on%252520AG3%252520iaStorV.png

On AS SSD the drivers could be (thanks "sub mesa" from THG forum):
"
- pciide.sys = microsoft IDE driver
- msahci = Microsoft AHCI driver
- iastor.sys = Intel AHCI/RAID driver
TRIM works with all these drivers in single mode, Intel from 9.6 RST version. But none of these drivers support TRIM on RAID.
AS SSD is a great SSD benchmarking tool, comparable to CrystalDiskMark.
Besides benchmarking you can also use it to:
- check your alignment (says GOOD if good, BAD if bad; that easy)
- lists the I/O driver you are using for that particular volume
- test whether NCQ is really working (the 4K-64 read score should be ~10x as high as 4K read score)"

Seeing everything looks ok, I decided to remove my windows 7 from the RAID and install a fresh one on the SSD. After it was done I first look on Disk Management to see how the new windows installed on the SSD and surprise!, the Windows installed indeed on the SSD but the "System reserved" partition was installed on the first partition of the RAID, that was formatted when I removed the old Windows. I wasn't able to find any solution to install the OS on SSD only as long as the SATA 1, 2 and 3 ports of the Intel controller are occupied by the three HDD's that make the RAID array. The "System reserved" partition is always created on the RAID. The only solution to this was to format again both drives (partition 1 from the RAID and the SSD itself), shut down and unplug the SATA cables from the RAID array, and finally install a fresh Windows 7 on SSD only. After I started new Windows and checked the "System reserved" partition and partition C:\ are correctly installed on SSD I plugged back the HDD's cables and the RAID started without problems without loosing data from the second partition. Then I get into Disk Management again and formatted NTFS the first partition of the RAID. After reboot all are working perfect and Windows is running from SSD only.


This is the version of the iaStorV.sys version on W7 original without SP:
J64b_SSD_iaStorV.sys%252520version%252520on%252520W7%252520original%252520without%252520SP.png

This is the version of iaStor.sys version on Win7 with SP1 and with Intel Rapid Storage Technology v.10.6.0.1002 installed:
J64b_SSD_iaStor.sys%252520version%252520on%252520W7%252520original%252520with%252520SP1.png

J64b_SSD_AS%252520SSD%252520on%252520AG3%252520iaStor.png

This is how Intel Rapid Storage Technology v.10.6.0.1002 reports my storage system connected to the Intel chipset (note that the ATA100 DVD-RW connected to Gigabyte controller is not shown here, only what is connected on the Intel controller):
J64b_SSD_Intel%252520Rapid%252520Storage%252520Technology.png

Looks like I have active the Intel AHCI/RAID driver, so i run other CrystalDiskMark test:

CrystalDiskMark v.3.0.1 (SSD OCZ Agility 3 60Gb on INTEL controller, AHCI and TRIM enabled) (run 2 with intel driver "iaStorV.sys" version 8.6.2.1014):
SEQ = 200.7 , 78.26
512K = 187.2 , 77.54
4K = 16.03 , 57.85
4K QD32 = 54.02 , 76.29

HD Tune v.2.55 (SSD OCZ Agility 3 60Gb on INTEL controller, AHCI and TRIM enabled) (run 2 with intel driver "iaStorV.sys" version 8.6.2.1014):
J64b_SSD_HDTune%252520on%252520AG3%252520%252528intel%252520run2%252529.png

Trying to see if the performance will improve with a new Intel driver I installed "Intel Rapid Storage Technology v.10.6.0.1002"

CrystalDiskMark v.3.0.1 (SSD OCZ Agility 3 60Gb on INTEL controller, AHCI and TRIM enabled) (run 3 with intel driver "iaStor.sys" version 10.6.0.1002):
SEQ = 200.7 , 77.84
512K = 187.4 , 62.45
4K = 16.91 , 60.58
4K QD32 = 51.88 , 60.88

Looks like performance actually decreased with the new driver. Maybe Intel improved other things like security in the new version detrimenting the speed? I will search for an answer for this sometimes.

OK, after few more digging days I found the problem of my SSD poor performance. Is not poor performance at all, but simply a different measuring drive speed technology. This SSD, like all the ones with Sandforce 2281 controller, use data compression to achieve higher data rates. Tests like CrystalDiskMark and AS SSD do not rely on data compression, that's why the results are so poor on them. Actually, the testing with AS SSD or Crystal DiskMark multiple times is not recommended because they write a large quantity of data, reducing the drive's overall lifespan and in some cases even locking the drive.
To achieve the speeds advertised on the specifications, the SSD must be tested with a benchmark that use data compression, namely, ATTO Disk Benchmark, the one used by OCZ itself. These results are the correct ones since in real world usage, the SSD will use data compression, thus achieving the advertised speeds.
J64b_SSD_ATTO%252520Disk%252520Benchmark%252520Jane.png
It can be clearly seen how from 64 Kb chunks, the speed of the drive is limited by the SATA2.


- TEST = Windows Experience Index. After this test looks like the slowest component of my system is the video card, which seem just right since I play games only occasionally, and I was looking for a video card with a really low power consumption at idle. According to a test I saw somewhere, Radeon HD 4670 consumes 9W at idle, 20W in typical 2D environment, 48W in typical 3D games, and up to 65W in extreme 3D load such as Furmark.
J64b_Windows%252520Experience%252520Index.png


A very interesting freeware program I found, SSD Life, can predict the lifespan of the SSD, measuring the amount of data read and write, and estimating how long the NAND memory will last (of course, if nothing catastrophic happens in the meantime). Besides that, it can show other useful informations like the status of TRIM, total data read/write, and other stuff.
J64b_SSD_SGT_2012.01.01_1536.58%252520SSD%252520Life%252520Jane.png

On the end, I figured out how to use this SSD without problems and after some days of usage I think I can finally made a good judgment how this SSD feels comparing with my previous RAID0 setup. In short: VERY WELL. All programs are launched now sensibly faster, the OS feels more responsive and I have no longer the feeling that I have to wait for HDD to finish loading before I can proceed with whatever I wanted to do. And my previous RAID0 setup made of three WD1001FALS of 1 TB drives, was really fast! Now I have the SSD as Boot drive with OS on it and the RAID0 I use for storage. I am very happy with my new SSD and I hope I will never have problems with it for at least several years from now on.
 

Fureh

Registered
Joined
Feb 2, 2011
Location
Colorado
Had to read a little, I have the 120gb version of that drive, and it posted the same scores as yours on a Sata II port, moving it to a III port made a world of difference, but thats not a option here, but yep...thats how mine looked on 2, was still pretty snappy, gets even faster on III.
 
OP
TyrAntilles

TyrAntilles

Registered
Joined
Jan 28, 2010
Yes, I bet is a lot faster on SATA3, but I wonlt change my motherboard just for that. And expansion card is not an option for me, so I have to stick with SATA2. Still, even with that the system is moving much better especially in mutitasking, and for me exactly that was very important, working often with ten or more programs in same time plus some that run on background.