• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

SOLVED p67 Intel raid 0 on Asus MIVE Problems

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

TsunamiJuan

Member
Joined
Mar 27, 2011
Location
Soviet Mexico
So Running into a buttload of troubles. I had it partly working when I tried to move stuff over from an existing windows 7 ultimate install that wasn't raided. To a Raid 0 setup. On new drives. I gave up with this since I couldn't get BCDEdit to properly install and see the drives so no booting :\

Then things got stranger while trying to do a fresh install. I make a windows disk with windows 7 ultimate sp1, and the most recent Raid drivers slipstreamed into the install. Windows fails to recognize the drives still despite loading the drivers. Taking things one step further i put the drivers on the storage drive outside the array, and loaded the drivers from that. Despite trying multiple drivers none of them seem to be the correct ones for windows 7 to see the drives correctly.

Here's the real kicker. When i go to browse I see the array. (no joke its there and working I can read from it even). In fact the storage drives off the same intel controller.

*grumble grumble grumble*

I spent most of yesterday screwing with this between family commitments till about 4am. Figured a good challenge is all ways a bonus. Worse cause i learn a bunch of new tricks (which i have in fact) and write an article for others. However the more reading I do about this seems to point to general problems with these controllers and this specific setup.

Hardware setup:
Asus Maximus IV Extreme B3 - bios 1409
i7 2700k (Oc doesn't matter here its been disabled and running at stock)
8gb of g.skill 2133 @ 11-11-11-30 1t
drives and config's-
2xintel 330 60gb ssd's striped
600gb wd raptor single

previous drive config

boot loader contained drive
1tb wd re4 intel - sata port 2 (this drive contains partitions and three windows installs aswell)
exteded drives
50gb ocz vertex 2 -intel sata port 1 - contains main windows partition
500gb wd black series - intel port 3
1tb wd black - port 4
2tb wd green - port 5
500gb wd green port 6

bios raid settings -
Intel sata mode - RAID
hot plug - disabled on all drives (incompatible with windows 7 if enabled)
smart - enabled (behaves the same with it off)

Marvell sata - enabled
sata mode - AHCI

Jmicron controller (esata controller)
enabled

misc crap -
I did have the system crash at once point after first turning on the intel Raid - resulting in MISC garbelled text during start up of the system (no errors thrown) It booted half way made it through post than crashed resulting in a hosed bios (infact the entire chip reset all settings and was forced to copy over the image from the other bios). Haven't had it do that again though. It was certainly odd. This was the 3rd boot after enabling intel raid with a full 5ghz overclock and a ton of additional power settings and other stuff enabled/disabled in the bios.


If anyone got some tips for me or knowledge on this please enlighten me. I read a bunch of Ciscoguy's posts on hardocp pertaining to this aswell. But its looking like this is a waste of time since intels controller has issues half the time with this type of setup.
 
Last edited:
OP
TsunamiJuan

TsunamiJuan

Member
Joined
Mar 27, 2011
Location
Soviet Mexico
turns out if you use the renasas usb3.0 ports to boot windows media off of with a usb3.0 device, the resulting wrapper masks the drive controllers in a weird way resulting in the inability for a fresh windows install to correctly see the intel and marvell drive controllers even when installing the correct drivers.

I didn't try the usb2.0 ports, since by the time i figured this out i was about through playing around and just want to get stuff installed. I'll try it another day on my other MIVE and see if it still causes problems.

The resulting problem manifested so strong that it prevented install even when raid was disabled, and all settings where at default. Which should of correctly allowed for clean booting/install.

side not this will also prevent correct useage and setup of BCDEdit, BootRec, and DiskPart from working. So it can hose the MBR of your start up devices is you said 3.0stick+ports as recovery media in case of a system crash.