• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

PC IS SHOWING NO SIGN OF POWER AT ALL...PLEASE HELP

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

umarrehman187

Member
Joined
Aug 31, 2009
ok you guys might know few weeks back my computer made a pop sound and turned off...i eventually found out that it was the power suppy....


well i got a new power supply....been working fine...i was doing my uni work....so i installed a software and i just restarted it....when i went back pc was offf...its not turnin on...showin no sign of power...i cannot smeel anything at all.....
 

JLK03F150

What have I done! Member
Joined
May 17, 2005
Location
Georgia
Sounds like another PSU failed on you. Can you disconnect the PSU from the mobo, jump start it (paper clip from Green to Black on the 24 pin connector) and see if it powers up to spin some fans?

The PC would boot, but would give you a CMOS checksum error if the battery was dead.
 

Dooms101

Member
Joined
Dec 28, 2009
Location
under a heatsink
Sounds like a dead board or CPU to me... it happened to me a while ago with an old HP. But it could be your power supply too. What kind of powersupply did you buy?
 

tinymouse2

Member
Joined
Jun 11, 2009
Location
Surrey, England
That's not a great power suply. I really wouldn't run anything on that, not even a string of LEDs.

Even if it's something else I would strongly reccomend getting a new power suply. Buy something branded and at least 70 quid (115 bucks+)

But yeh, try what JLK said. The paperclip trick is safe and it's VERY well known and helped show that my old PSU was completely deaded.

So yeh, splurge on a new PSU =P
 
OP
U

umarrehman187

Member
Joined
Aug 31, 2009
it sooo bloody funny that i took out the power cable jus turned the case side ways tried gettin the video card out, it was too hard, turned it to normal postions and its bloody workin WTF
 

Parad0x420

Member
Joined
Jun 22, 2007
Location
Dark Side of the Moon
it sooo bloody funny that i took out the power cable jus turned the case side ways tried gettin the video card out, it was too hard, turned it to normal postions and its bloody workin WTF

Power issues can be strange.. it may have been some kinda weird loose connection, or maybe you got a little 'card creep' on your video card, but I've never known that to stop a computer from turning on.
I had a strange power issue with random shutdowns and reboots to sometimes not turning on when I hit the power button. I opened up the case, double-checked all my electrical connections, cleaned the dust out of case and fans, and did a complete CMOS clear (removed the CMOS battery, moved the CLR jumper, discharged PSU by holding the power button, removed power connections to Mobo, and let it sit for a few hours). When I put everything back together and turned it on, I haven't had a single issue and has been solid since.. did several nights of just leaving it on and downloading torrents, and then OCCT at stock settings.. not one hiccup. :D
After finally being sure it wouldn't shutdown on me, I flashed BIOS to the most recent version.. and now I have my chip pushed to 3.86GHz @ 1.52v.. Really makes me want to buy a C3 955... :bang head
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
Sounds like its a shorting issue. I would remove the board and make sure its on the standoffs properly.
 

Archer0915

"The Expert"
Joined
Nov 3, 2008
I have one that does the same thing:) busted trace:( gotta wedge paper under it to keep it working:cool:
 

tinymouse2

Member
Joined
Jun 11, 2009
Location
Surrey, England
+1 for Archer0915. I just randomly stuck some paper under it to try and get it to work and it did! Still don't know why it worked =P
Still I would strongly reccomend a new PSU unless you want the parts of your computer to break. Might be alright but I wouldn't risk it.